Support » Fixing WordPress » Problems with .htaccess after installing WP in another subdomain

  • Good evening,

    Today I move my site to test/maindomian to domain. I use the DUPLICATOR plugin, eveything went well.

    In test/maindomain I have the permanent link setting as plain.

    In maindomain I changed the permanet linksto postname, so my .htaccess was the following
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    From that on, I got an error:
    Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

    Now I came back to plain, the .htaccess is:
    # BEGIN WordPress

    # END WordPress

    and everything is working.

    I read many post how to change the .htaccess to get rid of the error but most of them were old so I not sure what to so to fix that.

    Can someone please help me with this isssue.
    Thanks a lot in advance!
    Marcela

Viewing 10 replies - 1 through 10 (of 10 total)
  • Keith

    (@keithdriscoll)

    In your WP admin panel just resave your permalink structure. This will add the correct entries into your .htaccess file between # BEGIN WordPress and # END WordPress.

    Thank you so much Keith for your answer.

    This is what I did and the .htaccess that was addedd was the one I posted and it did not work.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    The thing is I saw many post with some correction in the line RewriteRule . /index.php [L]
    .
    But not sure if there will work because those post were for 2012.

    Thanks a lot

    Keith

    (@keithdriscoll)

    The standard .htaccess is shown here https://codex.wordpress.org/htaccess. So, it looks like you’re good to go!

    Sorry for the late response!

    Keith

    (@keithdriscoll)

    My bad! Here is a link to more info on the issue you are still having http://stackoverflow.com/questions/19071324/request-exceeded-the-limit-of-10-internal-redirects

    Good afternoon,

    Thanks for the link. I tried to follow it and I added the line : RewriteCond %{ENV:REDIRECT_STATUS} ^$

    Below you can see the file modified. But unfortunatly the I got an 404 error.
    Leaving the Permalink Settings as plain it works but I really want to change them.

    Thanks a lot again!

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{ENV:REDIRECT_STATUS} ^$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    Hello,

    Still haveing problems with this topic. Any help would be really appreciatte.

    Keith

    (@keithdriscoll)

    Can you post a link to the site you’re having this issue with?

    Hello,

    Thanks Keith, I have a test site but only for registered users. Could I pass the details privatly?

    @mcaso: Do not post login info in these forums. Keep support on this site. See http://codex.wordpress.org/Forum_Welcome#The_Bad_Stuff

    Sorry, I have not seen before, the Bad_Stuff.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problems with .htaccess after installing WP in another subdomain’ is closed to new replies.