WordPress.org

Support

Support » Plugins and Hacks » Polylang » [Resolved] Problems with Greek locale of polylang – Tranlation og Blog's title/subtitles

[Resolved] Problems with Greek locale of polylang – Tranlation og Blog's title/subtitles

  • Hi to all,

    I just started using polylang for my soon-to-be WP personal website. I started working on a Greek translation which I plan to contribute back when I solve this problem. I created the polylang-el_EL.po and polylang-el_EL.mo files and copied them under /wp-content/plugins/polylang/languages but I still see the English strings. The rest of the WP admin interface is in Greek. Any idea what could be the problem? Do you need me to send over the files for you to check?

    Another irrelevant question I have: Is it possible to have the Blog’s title and subtitle in two different languages?

    http://wordpress.org/extend/plugins/polylang/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Chouby

    @chouby

    For Greek, the WordPress locale is not “el_EL” but “el”. If you look at WordPress language files in wp-content/languages, you should find el.mo and not el_EL.mo. So you should name your mo file for polylang polylang-el.mo.

    Is it possible to have the Blog’s title and subtitle in two different languages

    Not in 0.5.1, but it will be possible in 0.6. You can try the current development version.

    Thanks for the fast response! It works correctly now.

    I may try the 6.0 edition and report any issues I find in the forum.

    Thanks again for the help and for putting man hours in this great plugin!

    You can find the .po and .mo files here in the ubuntucy.org forum in case you want to include them in the next release:
    http://www.ubuntucy.org/forum/viewtopic.php?f=15&t=1819&p=8856

    Plugin Author Chouby

    @chouby

    Thanks a lot for the Greek translation ! I will be happy to add it to the next release. Could you update it with the v0.6 strings ? If you download the development version, the pot file is updated. I will probably not change strings before the final release.

    I generally add a link on the plugin front page for each translation contributor. Should I link to ubuntucy.org or would you like another link ?

    Great to meet Linux users (Polylang is developped on a PC running Linux Mint, one of the numerous Ubuntu children…)

    Sure thing! I upgraded my test installation to 0.6 version and at first glance seems to be working fine.

    You can link it to the Ubuntucy forum as I have no better place to put it right now.

    I also did some minor corrections on the 0.5.1 version so if by chance you have already downloaded it please discard the first and download the corrected 0.5.1 version

    Plugin Author Chouby

    @chouby

    I just downloaded the 0.6 version that I will include with the next release. Thank you very much !

    Plugin Author Chouby

    @chouby

    Hello theodotos,

    I just released a development version of v0.7. I would be very glad if you could update the Greek translation. Thank you in advance !

    You can post it on your forum or here as you want.

    Frédéric

    I send it to the provided link above. You can also find it on the ubuntucy forum:
    http://www.ubuntucy.org/forum/download/file.php?id=153

    Plugin Author Chouby

    @chouby

    Thank you very much!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Problems with Greek locale of polylang – Tranlation og Blog's title/subtitles’ is closed to new replies.
Skip to toolbar