Support » Plugin: LiteSpeed Cache » Problems with Google Analytics, Google Tag Manager and Facebook

  • Resolved lechon

    (@lechon)


    We have been having problems with Lite Speed Cache

    Google Analytics and Google Tag Manager are “misfiring” when recording data.

    Under LiteSpeed Cache Page Optimization > Tuning > we have excluded the following:

    JS Excludes:
    gtm.js
    analytics.js
    adsbygoogle.js
    fbevents.js

    JS Deferred Excludes
    gtm.js
    analytics.js
    adsbygoogle.js
    fbevents.js

    But the problem still persists.

    When we entirely purge all caches, Google Analytics and Google Tag Manager seem to work with no issues, but that only last for 30 minutes or less.

    Facebook is Another Major Problem We Are Having,

    If we get a post on Facebook with thousands of clicks, the content is being served with no issues, but almost no clicks are being recorded by Google Analytics, and even our own internal raw server logs. As an example we had a post with over 5,000 clicks on Facebook and the server only recorded barely 100 of them.

    Looking at the data from analytics, it looks like many of the Facebook URLs are being stripped from the usual Facebook link you see:

    https://www.mysite.com/love-this-cat/?fbclid=jfwod734jeojdjhdohjd

    Stripped to this:

    https://www.mysite.com/love-this-cat/

    This is causing major havoc for us, can you please help us with this?

    Thanks

    Using Lite Speed Enterprise Server Version 5.4.11

    LiteSpeed Cache Report: QRTSFMPS

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems with Google Analytics, Google Tag Manager and Facebook’ is closed to new replies.