Support » Alpha/Beta/RC » Problems with embedding a video

  • Resolved bevived


    Since 2.7-beta3 I cannot properly embed a video. I use the Insert / Edit embedded media option, and paste a YouTube URL, and it shows up fine in the preview but not in the actual post when using Firefox 3.0.4). It works in IE7. The code being used is this:

    <object width="425" height="350" data="" type="application/x-shockwave-flash"><param name="src" value="" /></object>

    Up to 2.7-beta2 the code that would be embedded is this and it works fine in both FF and IE:

    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="425" height="350" codebase=",0,40,0"><param name="src" value="" /><embed type="application/x-shockwave-flash" width="425" height="350" src=""></embed></object>

    But when I edit the code manually, and change it to the ‘old’ one, it automatically reverts it to the new one that doesn’t work.

    Can anyone tell me how to fix this? Is this a problem of this specific beta or a problem with my theme (I can’t imagine it is as the old code works fine)? I would prefer not to use a plugin as technically WP can handle embedded media and I like to keep the amount of plugins I use at a low number.

    By the way, my blog can be found here: I use the most recent version of the Mandigo theme, if that makes any difference.

    Thanks for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I still haven’t solved this, so I would be very thankful for a reply. Thanks.

    I just created a test post using the youtube url you posted above via the insert/edit media feature in the visual editor. I then switched to the html editor and edited the movie size from the default 100×100, and published the post. It worked fine for me. Using 2.7 beta3, Firefox 3.0.4, (flashplayer 10 update installed). I also see the same video on your front page when I go here. Posted under “Dance Therapy” It seems to be playing fine for me on your site.

    Oh it does work for you? Weird, maybe it’s just me then. I will check if I have the most recent version of Flash installed. Thanks.

    Edit: I just downloaded the most recent version of Flash but it still doesn’t work. Hmmm…

    Okay, I just opened my blog in FF safe mode and it worked, so I figured it had to do with an extension. I disabled them one-by-one to see which one it was. Turns out it’s Adblock. I tried just wiping out the list of blocked sites, but it still doesn’t work. Looks like I have to disable Adblock for the videos to work. Not an ideal solution and I have no clue why this happens, but at least now I know it’s Adblock.
    Thanks for the help, turns out it had nothing to do with WP.

    Edit: I just downloaded a different extension to replace Adblock, the videos work with this one. Hooray!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems with embedding a video’ is closed to new replies.