Support » Plugin: Swift Performance Lite » Problems with Divi theme

  • Resolved gjefle

    (@gjefle)


    Hi – first off, I really LOVE Swift, but I cannot use it on several of my websites. All of them are built using Divi and the Divi Builder, and I have been experiencing many problems related to the Divi builder modules.

    Examples include entire module contents not showing up, pics in blurb modules not showing up, rows in parallax sections not showing up. It seems to have particular trouble with any of the full width modules.

    I’ve had to go back to using our old caching plugin even though we don’t get nearly the good performance results as when using Swift, but we need to have our page content show up. I would be extremely happy if this were resolved. Thanks!

    • This topic was modified 5 months ago by gjefle.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Contributor Fred

    (@fredawd)

    Hi,

    Most likely Merge Scripts/Styles causes your issue. Disable Merge and see if that solve your issue.

    Nope, disabled that as well as the built-in Divi CSS optimizing and it didn’t make a difference. I ended up changing the sections giving us problems (removing animations, parallax, etc.) just to make Swift work because it improves load speed so much more than other caching plugins we’ve tried.

    I had the same problem with Divi theme. Finally found a solution: disabling merging scripts and styles AND disabling Gzip. Now all works well including animations and the site speed is great.

    @fred: Still, it would be great if you guys could fix these issues with Divi theme.

    I’m running into the same issue on multiple sites all built with Divi. It appears that it happens to modules that are using the theme’s built-in animations. But not on all sites with animation, some are okay and some are not. The sites are using the very same plugins, so that shouldn’t be an issue. I’m confused as to why some sites are problems and some are not.

    As a note, wp-fastest-cache, which though is not overall as good a caching plugin as Swift, still correctly displays sections with the animations on all websites.

    • This reply was modified 4 months, 2 weeks ago by gjefle.
    Plugin Contributor Fred

    (@fredawd)

    there’s not a fixed set of options that should be activated on every website.
    Every site is different, and even if they might have Divi in common, several factors can influence the choice of the best Swift Performance settings. If you disable
    Normalize Static Resources, does that fix the issue?

    Just tried it and nope, didn’t make a difference. The stuff with animations are not showing. Thanks for the suggestion. I’ve tried tweaking a few settings with no luck.

    @gjefle I also think the problem occurs because of Divi builder’s specific modules. I forgot to say, I also excluded some URLs from caching, like /Layout_type/, /module_section/
    https://i.imgur.com/YDWfRw6.png
    I hope this helps.

    Normalize Static Resources is turned on for me.

    Because I can’t use merging styles and scripts with Swift, I use Autoptimize plugin for that and this combination (Autoptimize + Swift) works perfectly for me, much better than Autoptimize alone, or any other plugin I tried.

    this combination (Autoptimize + Swift) works perfectly for me, much better than Autoptimize alone, or any other plugin I tried.

    Autoptimize does not do page caching, so combining it with Swift for it’s great page caching capabilities makes a lot of sense actually 🙂

    frank (ao dev)

    Sorry not to respond for a few days – been uber busy. I’ve been doing a fair amount of caching exclusions and it seems to help sometimes. I will look into autoptimize when I get a chance. Thanks to all for their suggestions!

    Plugin Contributor Fred

    (@fredawd)

    Hey there,
    Since this topic has been inactive for a while, I’m going to go ahead and mark as resolved. Don’t hesitate to reopen or create a new topic if you still need help!
    Thanks for understanding!.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.