WordPress.org

Forums

Silverclean Lite
[resolved] Problems with Display on the iPhone? (6 posts)

  1. FlipperPA
    Member
    Posted 1 year ago #

    I was giving this theme a try, and noticed it doesn't display properly on the iPhone. Then menu bar displays fine on laptops, and on my iPad, but on an iPhone, the menu bar just becomes the gray navigation bar with no buttons. Is anyone else experiencing this?

  2. Iceable Themes
    Member
    Theme Author

    Posted 1 year ago #

    Hello, as stated in a notice you should have in wp-admin, you need to explicitly set a menu from Appearance > Menus for it to work properly in responsive mode.
    If you don't set your menu there, WordPress will use a fallback menu which doesn't work well (and simply disappears on mobile).

    In mobile mode, the navbar is replaced with a drop-down menu. When you touch it, the menu will appear with your phone's "pull down" menu, which is easier to use on a phone than the "normal" navbar.

    You can visit http://demo.iceable.com/silverclean-lite/ from your iPhone to see how it looks once the menu is configured.

  3. FlipperPA
    Member
    Posted 1 year ago #

    Thanks so much - that did the trick! If the client likes it, I'll encourage him to buy!

  4. queenofeverything
    Member
    Posted 1 year ago #

    Hi there - while this resolves the issues on mobile devices, it seems to cause a new problem when viewing on desktops/laptops. The drop-down feature of the menu disappears when Navigation Menu is unchecked. Is it not possible to have it functioning both ways? Working mobile menu and working drop down on desktop/laptop? Not sure if I am doing something wrong..

  5. Iceable Themes
    Member
    Theme Author

    Posted 1 year ago #

    @queenofeverything: I am not sure what is the issue exactly. A custom menu needs to be created and attached to "Navigation Menu" for the dropdown menu to work on mobile, and shouldn't cause issue in desktop view, unless maybe you haven't setup your menu as intended. Please review this page which contains extensive information about setting up menus: http://codex.wordpress.org/WordPress_Menu_User_Guide

    If you still have an issue when the menu is set please let me know and post a link to your site so I can have a look and see what else could go wrong.

  6. queenofeverything
    Member
    Posted 1 year ago #

    Thanks very much Iceable, I was able to figure out what I'd done wrong based on your response.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic