Support » Fixing WordPress » Problems with changing the author of a post

  • Hi there,
    I found many pages with the explanation of how to change the author of a post but none of them work for me, since the Author field does not appear in any of the places where I can edit a post (QuickEdit, Gutenberg Editor).
    What could be the problem?

    I have changed a category for a post and automatically I have been assigned as the author of the post. I have tried to go back in the revision so that the original author stays but it does not work, my name as author stays still there. What can I do?

    Thank you very much in advance.

    Best regards

Viewing 6 replies - 1 through 6 (of 6 total)
  • @vmarin87

    When you view all your posts from the backend, make sure show Author is enabled :
    https://imgur.com/a/qyPadxX

    However, you can also do this in bulk, also from your Posts page :
    https://imgur.com/a/bSPqVoH
    https://imgur.com/a/AbKtHmr

    Victory

    (@vmarin87)

    Hi!
    Thanks for your answer.
    Yes, Author was enabled, but still it is not shown anywhere like in the two last screenshots…

    corrinarusso

    (@corrinarusso)

    @vmarin87

    I dunno then. You’ll need to post more information with a screenshot, or screencast.

    Hi!
    We are experiencing the same issue described here: https://github.com/WordPress/gutenberg/issues/3010
    As I see from the page, this should have been already fixed by now (it is a closed issue), but there is a last reply in which seems that someone else is still having problems, as us. We do not have any possibility to change the author of a post or page, and anytime we edit a post just to add it to the right category, the authorship of the post changes and the original author is not shown any more.
    Is there any way we can fix that, or some plugin that could solve this?
    (We have a multisites installation and the last WP version)
    Thank you very much in advance.

    • This reply was modified 2 weeks, 2 days ago by Victory.

    @vmarin87

    I personally have little experience with Multisite.
    Do you meet this criteria ?
    Note: For the author selection drop down to appear there need to be at least two users with the capability to edit the post.

    Otherwise, I would add to the issue on GitHub.
    Be sure to include details of your site setup.

    Victory

    (@vmarin87)

    Thank you for your answer! Our IT department has found out that it has to do with our configuration of user roles, which are custom defined.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.