WordPress.org

Forums

zAlive
[resolved] Problems with blog (9 posts)

  1. wolfsongblue
    Member
    Posted 1 year ago #

    I'm trying to set up a website with this theme, but I'm having trouble getting the blog working properly. Here is a link to the site: http://www.firedupgeckos.com/

    I want to have a static page for the homepage with the slider. Then I do not want to have the slider appear on any other pages. It looks like I have that working properly. But if you go to the "Blog" page, the slider shows back up. Is there a way to disable the slider from the blog while still having it appear on the homepage?

    Also when I go to the blog, the posts seem to be appearing properly, but if I click on either of the posts to try to go to the individual post, I get a "Error 404,Page Not Found." Do you know what is wrong?

    Thank you for your help!

  2. Gezim Basha
    Member
    Posted 1 year ago #

    Have you done any custom editing to the .php files?

    You've probably edited the slider into the index.php file. Probably not the best idea. Let us know how you managed to remove the slider from the other pages?

  3. wolfsongblue
    Member
    Posted 1 year ago #

    I haven't done any custom editing (I actually just installed the latest version 1.2.9 thinking maybe it was a bug but that didn't make any difference).

    For this theme, if I go to "Appearance" and then to "Theme Options" there are options for the slider including "Enable or Not." There I have three choices:

    Enable - this enables on all pages
    Enable in Home Page - this is the option I have selected, which enables it on both the home page and the blog
    Disable - this disables it from all pages

  4. zenoven
    Member
    Theme Author

    Posted 1 year ago #

    Hi, to the slider issue maybe that is bug and I'm sorry for that. I'll check and fix it.

    And to the Error 404 issue, that is because posts got wrong URLs, 'Testing blog' and 'Welcome!' have the same URL,have a look at your settings ?

  5. zenoven
    Member
    Theme Author

    Posted 1 year ago #

    New version(1.2.11) has uploaded and needs to be reviewed by admins, you can download and try it now in developers tab

  6. wolfsongblue
    Member
    Posted 1 year ago #

    Thank you so much for you help! I downloaded the new version and that fixed the slider issue.

    I'm not sure how to fix the 404 error issue. Here is what I have for settings:

    I created two pages: "Welcome" and "Blog." Then under Appearance and Customize, there is the option for "Static Front Page." Under that, I have it set so that Front page displays a static page. I have the "Welcome" page set as the front page and the "Blog" page set as the posts page.

    The blog page seems to be displaying the posts, but when I click on either of the posts, I get a 404 error saying and the url is http://www.firedupgeckos.com/welcome That is the url for the "Welcome" page, which is the page that is currently set as the homepage.

    Any ideas on what I could do to fix this? Is there any chance this is a bug as well?

    Thank you again for your help!

  7. zenoven
    Member
    Theme Author

    Posted 1 year ago #

    I also created two pages in my local machine, one page set to the homepage and the other to the blog, all goes well.

    This thread reported sth similar with your, that may be helpful.

    And a quick to test whether it's a bug with the theme, just switch the theme to another such as the WordPress default one.

  8. wolfsongblue
    Member
    Posted 1 year ago #

    Thank you! That thread was helpful and so was the suggestion to test with another theme (the problem was still there with a different theme). I did figure out the problem. Here was my solution in case anyone else has a similar problem.

    Under settings and then permalinks, I had set it to "custom structure" with http://www.firedupgeckos.com/welcome as the custom permalink. I don't even remember setting it to that (but I tend to work on my projects late at night, so who knows how it happened!) Switching from "custom structure" to "post name" fixed my problem.

    Thank you again for all of your help!

  9. Windykacja
    Member
    Posted 1 year ago #

    I've got the same prblem byt I did some custom editing to the .php files.
    how can I remove the slider from the other pages?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.