Support » Plugin: OMGF | Host Google Fonts Locally » Problems with activated OMGF

  • Resolved duerrundsteidle

    (@duerrundsteidle)


    When I run OMGF it installs the fonts on our server. This works great and when I look it up I see that no more unwanted connections are established.

    Now I have noticed that my site becomes very slow.

    If I deactivate the plugin my site is fast.

    No matter if I have it activated or deactivated it accesses the fonts on my server which is good but I don’t really understand the phenomenon?

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi!

    Ok, so OMGF does what it’s supposed to do, but it slows down your site?

    Then your server must have issues, because a locally hosted file should always load faster than an external one.

    You did flush your caches after configuring OMGF? If so, it might just be that your site is slow because it’s rebuilding its cache. It happens on some servers.

    Or another plugin is interfering with OMGF, slowing it down. Try to disable all plugins, except OMGF, flush cache and monitor the loading time (with e.g. Pingdom or GT Metrix). Then disable OMGF as well, flush cache and monitor it again.

    Which version of PHP are you running?

    Get back to me with your findings.

    @duerrundsteidle What’s your site URL?

    As I said, the problem is not the server. When I disable OMGF it loads the font from the server and the page is fast. But when I activate it, the page is slow. Enabling and disabling does not change the font loading process.

    I am running PHP 7.3.

    My URL is https://webmutanten.de

    Your site runs Autoptimize and the page contains errors (see browser console). You should resolve these errors first.

    Also, when the plugin is activated, Autoptimize may recreate its cached files, which takes time. Is the site consistently slow?

    Finally, is there any caching involved?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Thanks for helping out, @galbaras 🙂

    Thanks for the error I need a little bit time to look.

    If I deactivate Autoptimize there is no other result.

    The site is always slow also after more hours.

    If I test the speed with PageSpeedinsights I can#t measure it because it’s to slow for it. This mesaage occures.

    Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Die von Ihnen angeforderte Seite konnte von Lighthouse nicht zuverlässig geladen werden. Überprüfen Sie, ob Sie die richtige URL testen und der Server auf alle Anfragen angemessen reagiert. (Details: net::ERR_TIMED_OUT)

    And no there is no caching involved.

    @daanvandenbergh It seems like there’s an issue when something expires.

    Does the plugin hold up a page while it updates fonts from the Google servers?

    Does it connect to any other external service, like a support/usage beacon?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Hi Gal,

    No, it doesn’t. In the frontend, OMGF only enqueues a stylesheet to load the fonts. Nothing else.

    What do you mean ‘when something expires’?

    Does the plugin ever refresh the font files?

    I’ve tested the latest version on one of my sites and didn’t notice any degradation in performance.

    Anyway, the OP’s site doesn’t seem to be loading local fonts at the moment, and whois is returning a strange result for it, which implies there may be a domain registration issue involved.

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    Ah, that’s what you mean. No, fonts never expire and there are no font replacement or update scripts involved.

    As I said no matter if the plugin is enabled or disabled it always loads the fonts from my server.

    The only difference is that when it is activated the site is very very slow. But if the plugin does nothing when activated I wonder how that can be?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    You could try the Auto Detect feature. OMGF should be able to replace the fonts it detects effectively.

    You have the ‘Remove Google Fonts?’ option enabled, I assume?

    Plugin Author Daan van den Bergh

    (@daanvandenbergh)

    @duerrundsteidle,

    I just took a look at your page’s source code and I noticed that it loads Poppins and Roboto Condensed using a Web Font Loader (in ALL available subsets, btw. < you should tweak this). Since Web Font Loader makes fonts load asynchronously using javascript, OMGF can’t detect them. In a way, they don’t ‘exist’ yet on pageload.

    You could look if your theme or page builder allows you to disable the Web Font Loader. Then re-run Auto Detect. If not, you’ll need a custom implementation for your theme to disable the Web Font Loader. If you need help with that, I can help you with that.

    I had used the Auto-Detect function to install the fonts.

    ‘Remove Google Fonts’ is activated.
    If I deactivate this, there will be no improvement.

    OK thank you very much for the search and error detection. But I still don’t understand what this means and how I can fix it? Would be very grateful for further help.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.