Support » Plugin: Advanced Access Manager » Problems with AAM Cache (Error 500)

  • After the latest update, in the site often occurs “Error 500”.
    If I clear the cache with the appropriate function
    Settings > Clear AAM Cache
    the problem seems resolved, but after a few hours returns Error 500.
    Is there a way to solve the problem permanently?

    ———————————-
    AAM 5.7.2 + PlusPackage v3.9
    WooCommerce 3.5.3, Yoast Seo 9.3, WP bakery 5.6
    Wordpress 5.0.2
    ———————————-

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author AAM Plugin

    (@vasyltech)

    @flyangel,

    Please check PHP error log and let me know what errors do you see there.

    Thank you.

    In the error_log file there is a large amount of these errors

    [30-Dec-2018 17:58:44 UTC] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/myaccount/public_html/wp-content/plugins/techone-toolkit/includes/shortcodes/custommenu.php on line 47
    [30-Dec-2018 17:58:44 UTC] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/myaccount/public_html/wp-content/plugins/techone-toolkit/includes/shortcodes/custommenu.php on line 47
    [30-Dec-2018 17:58:45 UTC] PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /home/myaccount/public_html/wp-content/plugins/techone-toolkit/includes/shortcodes/custommenu.php on line 47

    but I do not understand why, when I clear AAM cache, the site returns to work.

    • This reply was modified 1 year, 8 months ago by flyangel.
    Plugin Author AAM Plugin

    (@vasyltech)

    Hi @flyangel,

    The warnings that you’ve mentioned do not really cause any issues, besides that are not even related to AAM. So there is something else going on.

    Seams like the AAM cache is keep backing up until and I’m not quite sure why that is the case.

    – How many users does your website have?
    – As well as, do you have any special settings defined in ConfigPress?
    – Finally, what is your PHP version and memory limit?

    Plugin Author AAM Plugin

    (@vasyltech)

    Oh and one more questions:

    – How many posts, pages, CPTs your website has.

    Thank you,
    Vasyl

    Thank you Vasyl, the problem occurred many other times yesterday (every 3 or 4 hours). All the time I have solved by deactivating AAM plugin (via FTP) and then reactivating it. Today (6 hours ago) I tried to reactivate the plugin but leaving the “Plus Package” turned off … and the problem has not yet occurred.

    – How many users does your website have?

    1 administrator, 1 shop manager, 2885 registered users (customers).
    The site has no big traffic, about 5 orders a day, or even less.
    Some days even there are no orders.

    – As well as, do you have any special settings defined in ConfigPress?

    I have not ConfigPress

    – Finally, what is your PHP version and memory limit?

    – PHP version: 7.2.12
    – Memory limit for WP: 256 MB

    – How many posts, pages, CPTs your website has.

    0 posts, 30 pages, 3110 products in WooCommerce.

    ———————————————————–
    If it can be useful, this is my configuration
    GENERAL INFO:
    – WooCommerce version: 3.5.3
    – WordPress version: 5.0.2
    – Memory limit for WP: 256 MB
    – Server info: Apache
    – PHP version: 7.2.12
    – PHP Post Max Size: 8 MB
    – PHP limit time: 30
    – PHP Max Input Vars: 1000
    – Version cURL: 7.60.0, OpenSSL / 1.0.2k
    – MySQL version: 10.0.36-MariaDB-cll-lve
    ———————————–
    DB INFO:
    – WooCommerce database version: 3.5.3
    – Total database size 348.58MB
    – Database data size 257.29MB
    – Database index size 91.29MB
    ———————————–
    ACTIVE PLUGINS:
    – Redux Framework 3.6.15
    – Advanced Access Manager 5.7.2 (+ Plus Package 3.9)
    – WPBakery Page Builder 5.6
    – Custom Login Page Customizer 2.0.1
    – Participants Database 1.8.4
    – PayPal for WooCommerce 1.5.4
    – TechOne Toolkit 1.0.7
    – WooCommerce Checkout Manager 4.2.3
    – WooCommerce Extra Charges To Payment Gateway 1.0.12.9
    – WooCommerce PDF Invoices & Packing Slips 2.2.5
    – WooCommerce POS 0.4.21
    – WooCommerce Stock Manager 1.2.8
    – WooCommerce 3.5.3
    – Yoast SEO 9.3

    • This reply was modified 1 year, 8 months ago by flyangel.
    • This reply was modified 1 year, 8 months ago by flyangel.
    Plugin Author AAM Plugin

    (@vasyltech)

    @flyangel,

    Thank you so mych for sharing all these details. I promise to find the reason as it is the highest priority task for me right now.

    I need one more favor from you. When next time 500 occur. Can you make a database dump of wp_options & wp_usermeta? Then send it to me via email support@aamplugin.com.

    This way I will be able to figure out the problem.

    After you do that, disable the AAM cache by entering this config on the AAM page on Settings ConfigPress tab:

    [aam]
    core.cache.status = disabled

    Thank you!

    Its something that you’ve changed on the last update. I restored the website to previous version (previous plugin version), and its working perfectly.

    i’m having the same problem. today i wil do more testing but i updated yesterday and it was the only plugin active that crashed my site (error 500).

    also, for some reason, when i installed the 5.7 the site worked again, but no AAM settings were working and the site was fully accessible to everyone (i did not make any changes to the database) i had to restore a complete backup of the site.

    edit: i have a working 5.5 version. full plus package active. if i update the plus package the site become public for everyone (must be private to non logged users)

    the settings page shows this:

    The content-teaser/config.php file is missing. Update extension to the latest version. Read more.
    The login-redirect/config.php file is missing. Update extension to the latest version. Read more.
    The redirect/config.php file is missing. Update extension to the latest version. Read more.
    The role-filter/config.php file is missing. Update extension to the latest version. Read more.
    The Complete Package extension has new update available for download;
    The E-Commerce extension has new update available for download;
    The User Activities extension has new update available for download;

    after the update of the package (not the plugin, i cant do it!)

    The content-teaser/config.php file is missing. Update extension to the latest version. Read more.
    E-Commerge requires AAM v5.6.1.1 or higher.
    IP Check requires AAM v5.6.1.1 or higher.
    The login-redirect/config.php file is missing. Update extension to the latest version. Read more.
    Plus Package requires AAM v5.7.2 or higher.
    The redirect/config.php file is missing. Update extension to the latest version. Read more.
    The role-filter/config.php file is missing. Update extension to the latest version. Read more.
    Role Hierarchy requires AAM v5.6.1.1 or higher.
    The User Activities extension has new update available for download;

    i’ll send you a mail with more info. thanks

    • This reply was modified 1 year, 8 months ago by MGDel.
    • This reply was modified 1 year, 8 months ago by MGDel.
    • This reply was modified 1 year, 8 months ago by MGDel.

    Can we update the plugin or the new version is still with this error?
    Tks

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problems with AAM Cache (Error 500)’ is closed to new replies.