WordPress.org

Support

Support » Themes and Templates » Problems with a page template..?!

Problems with a page template..?!

  • Uffe

    @uffe-kirkegaard

    Hi..

    I am stock with this. For some strange reason this page template of mine works fine in Google-Chrome and Apple-Safari browser, but looks really odd in Explore browser..

    Any ideas how to fix it..??

    The page is this:

    http://uffekirkegaard.dk/blank-2

    Kind regards
    Uffe

Viewing 3 replies - 1 through 3 (of 3 total)
  • Michael

    @alchymyth

    Forum Moderator

    esmi

    @esmi

    Forum Moderator

    Start by sorting out the markup errors. Then move onto the CSS errors.
    http://codex.wordpress.org/Validating_a_Website

    Uffe

    @uffe-kirkegaard

    Thank you both for the quick reply…

    I have tried to see if I could figure out these markup errors. But I must admit that my knowledge at this moment, don’t stretch this far…

    The code from the page template looks like this:

    <?php
    /**
    	Template Name: Uffes fullwidth
    
    */
    ?>
    <html>
    <head>
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <style type="text/css">
    body { background-color: #cccccc; background-image: url('http://uffekirkegaard.dk/wp-content/uploads/2010/10/bg.jpg'); background-repeat: repeat-y; background-position: top center; background-attachment: scroll; }
    </style>
    
    <title><?php wp_title( '|', true, 'right' ); bloginfo('name'); ?></title>
    <?php wp_head(); ?>
    </head>
    
    <body>
    <?php while (have_posts()) : the_post(); ?>
    <div id="container" class="uffes-fullwidth">
    			<div id="content" role="main">
    					<div id="page-content">
    					<?php the_content(); endwhile; ?>
    					</div>
    			</div>
    </div>
    </body>
    </html>

    …and as far as I can read this IS how a page template should begin..!? or am I wrong..?

    So how does this <html> doc.type error fit in..?

    Hope you guys are able to shine some light my way.. :o)

    Thanks very much for the help..

    Ps. It looks like some of the errors comes from plugins..! Is this true you think..?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems with a page template..?!’ is closed to new replies.
Skip to toolbar