Support » Plugin: Fast Secure Contact Form » Problems with upgrade: attachment error message on form

  • Resolved Abigailm


    Since plugin upgrade, this message appears on my contact form (printed in red):

    Please make corrections below and try again.
    The temporary folder for the attachment field is not writable.

    However, I have set permissions in the attachment folder to 0775 and tested the form. Attachments can be sent with no problem, although form is slow to refresh.

    There is an .htaccess file in the attachments folder which specifies:
    Deny From All

    I know that whenever I upgrade the plugin I have to check permissions on the attachments folder, but always before any error messages went away once I did that.

Viewing 4 replies - 1 through 4 (of 4 total)
  • OK – I have resolved the problem. I don’t know why it occurred but here is what I did.

    1. Set permissions on attachment folder so that it is NOT writable. (0555)
    2. Reload contact form submission page – error message displayed.
    3. Reset permissions on attachment folder to 0775
    4. Reload contact form submission page again. (Error message is now gone)

    I don’t know why this worked…. but I thought I should share it in case anyone has a similar problem.

    The problem is that the attachments folder needs to be writable by the web-server.

    Changing the folder permissions to 0775 does not help if the Group ownership is not in the group for the web server.

    You may need to run both of the following commands

    chown -R <user>:apache <wp install folder>/wp-content/plugins/si-contact-form/attachments
    chmod -R 775 <wp install folder>/wp-content/plugins/si-contact-form/attachments

    This assumes that your webserver is running as Apache.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Check with your host first as different hosts run different distributions of the OS with totally different user and group ids.

    Thanks to Abigailm for your suggestion.
    In my set-up I changed the permission settings to 555 and reloaded the page as suggested. I then set the permissions to 776 and the red text warnings disappeared. For interest, I then tried 775, but the message reappeared so I reset he permissons to 776 and ok again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems with upgrade: attachment error message on form’ is closed to new replies.