Support » Fixing WordPress » Problems with 3.0.4 upgrade

  • I upgraded to 3.0.4 this morning (I believe I was previously running 3.0.1) after seeing the security warnings and Media Temple setting up the automatic update button to work for the newest version.

    It appeared to go without a hitch. However, now when I go to the list of my posts, nothing is there; the posts still appear on my site, and it says it’s showing me 1-20 of 312 posts. When I go to the editor, the whole right sidebar that I had previously is gone; no way to add tags or set up a delayed posting. The editor looks like an older version. I get this behavior in both Safari and Firefox. When I tried to make a post with an image in the visual editor, it does not show the image like it used to, just the html code.

    Is this just something I need to wait to straighten itself out (database refreshing)? Or is this an actual problem with the upgrade?

Viewing 15 replies - 1 through 15 (of 18 total)
  • check what plugins you have installed (especially if it’s one for the admin pages), maybe one of them in incompatible or also needs to be upgraded.
    to disable a plugin just remove its folder from the plugin directory

    @mosco Akismet and Hello Dolly are listed in my Plug-ins, but I never activated them. Would they still affect things?

    No, not if they’re inactive, they should have no impact. Not sure what else it could be, sorry.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I would try a Manual update, as it sounds like something didn’t get copied up correctly.

    http://codex.wordpress.org/Updating_WordPress#Manual_Update

    Okay, I overwrote my wp-admin, wp-includes, and the few files from the wordpress folders. Still unable to see my posts list and the editor still appears to be from an older version. When I run upgrade.php it says I’m up-to-date.

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    @esmi Already use the TwentyTen theme, and yes, refreshed plugins folder per your post in another thread.

    I’ve also discovered that if I open a post from my blog site using the Edit link or if I open a draft that’s listed on the Dashboard I get an editor that looks like it should (i.e., the right side bar is there with all the tag fields, etc.) as opposed to the editor I get from just clicking on Add Post, which just has what appears in the center.

    ETA: In the editor, there appears to be a problem differentiating between the visual editor and the HTML editor.

    esmi

    (@esmi)

    Forum Moderator

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    @esmi Done. But it doesn’t seem to have made any difference. 🙁

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Okay, I overwrote my wp-admin, wp-includes, and the few files from the wordpress folders.

    Given that everything was working before, I would go so far as to DELETE the wp-admin and wp-includes folders and reupload them. Won’t hurt anything.

    True, what Ipstenu said.

    Normally when FTPing files to a site, everything gets overwritten; however, WP has enough files and folders that sometimes something gets missed. Better to delete and upload.

    @ipstenu For the just in case, I went in and deleted the files then uploaded them fresh. Still looks the same in regards to the editor and the posts list.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    What version of PHP are you running?

    This is pretty odd… You used the WordPress updater originally, right? Not one from Media Temple.

    @ipstenu I honestly have no idea how to check the version of PHP I’m running. And, yes, originally I used the upgrade button from the WordPress dashboard, not from within my Media Temple account (which oddly still seems to think I’m using 3.0.1).

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Don’t bother with MediaTemple’s upgrader, FWIW. It’ll make things worse 🙂

    You’re the second person I’ve seen with TinyMCE problems like this (which still makes this insanely rare).

    Download a fresh copy of WordPress from http://wordpress.org/download/ and re-do the deletion of wp-admin and wp-includes

    Also check for a .maintenance file in your main WP folder. If it’s there, delete it.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Problems with 3.0.4 upgrade’ is closed to new replies.