[resolved] Problems with 3.0 (21 posts)

  1. nontechblogger
    Posted 4 years ago #

    WP 3.0 doesn't work for me. How do I downgrade to the older version? Do I install it over in cPanel?

  2. Unless you have a backup that you can restore from, downgrading is an immensely difficult (if not impossible) process, which is why backing up before upgrading is strongly recommended both in the upgrade instructions and automatic upgrade interface.

    It would be better to solve your current problem. Can you describe what is wrong?

  3. bingofuel
    Posted 4 years ago #

    I upgraded as well and stupidly ditched my backup. I'm currently receiving the following fatal error and don't really know how to fix it. If anyone has any clues for how to fix it, I'd be grateful:

    Fatal error: Call to a member function add_rewrite_tag() on a non-object in /home/theuroz6/public_html/wp-includes/taxonomy.php on line 289

  4. Windhamdavid
    Posted 4 years ago #

    the error from the add_rewrite_tag() is likely from a plugin that needs to be updated -http://core.trac.wordpress.org/ticket/13957 ~ try disabling all plugins.

  5. bingofuel
    Posted 4 years ago #

    Thanks Windhamdavid...

    Turns out 3.0 really doesn't like the podcasting plugin at all... which is a shame, since podcasting is one of the primary raisons d'etre for my website. :(


  6. storaord
    Posted 4 years ago #

    I have a few WP-installations at one.com. During the third installation something went terribly wrong. I tried to repair it but...
    Does someone know what this means?

    wp_posts: Table 'dagensgolf_se.wp_posts' doesn't exist
    wp_comments: Table 'dagensgolf_se.wp_comments' doesn't exist
    wp_links: Table 'dagensgolf_se.wp_links' doesn't exist
    wp_options: Table 'dagensgolf_se.wp_options' doesn't exist
    wp_postmeta: Table 'dagensgolf_se.wp_postmeta' doesn't exist
    wp_terms: Table 'dagensgolf_se.wp_terms' doesn't exist
    wp_term_taxonomy: Table 'dagensgolf_se.wp_term_taxonomy' doesn't exist
    wp_term_relationships: Table 'dagensgolf_se.wp_term_relationships' doesn't exist
    wp_commentmeta: Table 'dagensgolf_se.wp_commentmeta' doesn't exist

  7. richardneililagan
    Posted 4 years ago #

    @storaord ~ Looks like a database issue. Where does this come up? O__O

  8. kaotik
    Posted 4 years ago #

    Was this version of WordPress ready to release to the public yet? Seems there's lots of issues here.

  9. Metzgerr
    Posted 4 years ago #

    I'm not able to login to /wp-admin with Firefox only - Chromium works

    WP 3.0 under Ubuntu

  10. Member111
    Posted 4 years ago #

    I seem to not be able to add categories.

  11. Everyone, please start a new topic for your problems. All of you hijacked nontechblogger's topic and turned it into a "I have a problem too" mess. I'll try answer your problems, but if it doesn't resolve it, start your own topic.

    bingofuel, upgrade the Podcasting Plugin by TSG to 2.3.10.

    storaord, check and confirm the settings in your wp-config.php file.

    kaotik, it was ready to be released a while ago. Most of the issues are related to plugin conflicts, specifically to plugins that use functions which were warned of being obsoleted back in WP 2.9.

    Metzgerr, there's nothing in WP that would prevent admin access on a browser-specific basis, you should probably ask in the Firefox support forums.

    Member111, disable the HeadSpace2 plugin.

    Again, if this did not resolve your issue, please start your own topic.

  12. nontechblogger
    Posted 4 years ago #

    Thanks macmanx. A couple of reasons. I've been having plugin conflicts in previous wp version. In 3.0, I seem to be having even more conflicts.

    I'm also seeing memory error in my dashboard:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3789528 bytes) in /home/eyamane/public_html/wp-includes/class-feed.php on line 4

    If I reinstall wp in cPanel, does it not replace the current installation?

  13. If you reinstall WP, you'll lose all of your content.

    Try these steps to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    4. Talk to your host.
  14. nontechblogger
    Posted 4 years ago #

    If I upload wp-admin and wp-includes folders only, I won't lose my content. I've actually done that before, but it was the same version. Would this work when downgrading versions?

  15. No, because the database has been upgraded for 3.0. You can't run a WordPress 3.0 database with WordPress 2.9.2 files.

    Try the steps quoted above to increase PHP's memory allocation.

  16. junglequeen
    Posted 4 years ago #

    The upgrade worked fine for me on 2 of my blogs, but now the "Insert Image to Post" facility will not work. Instead of the miniscreen I get a full screen that does add the image to Media - but definitely does not add it to the post.

    This is a real issue for people whose blogs are set up to display images or photos. Does anyone else have this problem? I'm reluctant to upgrade any more of my blogs now.

  17. Everyone, please stop hijacking nontechblogger's topic. Start your own, please. nontechblogger is actually trying to solve a problem here, but all everyone else seems to care about is stopping by to say, "Oh, I have a completely different problem."

    If you have a completely different problem, please start your own topic.

    These are the WordPress Support Forums, not the WordPress Support Topic.

    Please start your own topics, or I'll have to start hacking and slashing replies without notice until some sort of order is established.

  18. kentucky
    Posted 4 years ago #

    Jungle Queeen see http://wordpress.org/support/topic/411617?replies=27#post-1559350 for your issue. Hasn't been solved as of this morning though.

  19. nontechblogger
    Posted 4 years ago #

    I've tried the memory. I don't have access to php.ini. I modified the .htaccess and it caused internal server error. My wp-config is already bumped up to 256. I've contacted my host and they are looking into it. Hopefully they'll be able to resolve it which resolves my wp issues.

  20. Also, try this plugin (it's new, so I forgot about it, sorry):


  21. lorenzo-romani
    Posted 4 years ago #

    For me problem caused from no updated "sitepress-multilingual-cms" and "mailpress" plugins, i resolved it simply delete plugings, now i try install newer version an then i refer to you new result.

Topic Closed

This topic has been closed to new replies.

About this Topic