WordPress.org

Support

Support » Plugins and Hacks » Comprehensive Google Map Plugin » [Resolved] Problems when hidden on load

[Resolved] Problems when hidden on load

Viewing 15 replies - 1 through 15 (of 16 total)
  • kayosdesign

    @kayosdesign

    Hi,

    Has anyone managed to solve this issue?

    I have a site using a fairly stock bit of jquery to switch between tabs. The tab displayed when the page loads works fine, however the hidden maps display as shown in the link above.
    Demo here

    If you resize the page then the map tiles load, but the map does not reposition itself.

    I have found this, which seems to be related. I think the map just needs to be told to refresh somehow, or resized, but I have no idea how to do it in WP + CGMP

    Any advice would be appreciated.

    Cheers,

    D.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Hi NerdAtWork…

    Are you still active here?

    kayosdesign

    @kayosdesign

    If there is an easy solution then I would like to know it, but I have worked around the problem.

    I went old style and forced each tab to actually reload the page. Now I am only loading one map per page.

    Cheers,

    D.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Wait until v8.0.2, I am hoping that the fix I have applied will resolve this issue

    NerdAtWork

    @nerdatwork

    I’m still active, but haven’t used the plugin now because of the problem described. Deleted without substitution… ;o)

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Gotcha.. Give it ago again if you can..

    YES.. works now! Thx. :o)

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Really? Are you able to provide a link to the live site?

    Sorry.. just tested in on a draft page. But as I just want you to provide a screenshot and called it again – the old ‘buggy’ view is presented again. Strange… but is has worked.. one time.. I swear. ^^

    Edit: If it helps. At first the old view was loaded – and then the nice one – as if it reloads itself. Could it just reproduce with some page reloads. But unfortunately it’s seems not fixed at all.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Its a bit hard to test without viewing the actual page – are you able to help me?

    Hey. You don’t have a wordpress for testing? ^^

    Take a look here – but in time please:
    http://www.aktivtreff-ruhr.de/treffpunkte/

    Pop out the last point in the list…

    Was the same for me… works… works not.. and then only works sometimes.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Actually, I just pushed a fix for jQuery tabs + plugin conflict. Tested on my wordpress.

    BUT, having said that, it will work with jQuery tabs only. Tabs that use jQuery CSS classes. I know its not generic enough at the moment.

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    You can have a look at non-min JS to see what I have done

    Plugin Contributor alexanderzagniotov

    @alexanderzagniotov

    Ohh sorry. Please get version 8.0.5.1. The solution is generic now, regardless of CSS selectors… I keep checking if the map placeholder DIV is hidden or not, the moment it becomes visible – I resize the map

    Can you mark it as update – so WordPress shows ‘There is an update available for the plugin’ ?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] Problems when hidden on load’ is closed to new replies.
Skip to toolbar