Support » Plugin: WP Offload S3 Lite » Problems uploading to s3

  • ppops

    (@ppops)


    I’m having some trouble getting this plugin to work.

    I have selected the correct bucket in the settings but it still won’t upload to s3.

    It is though it tries because uploading a small 100kb image takes 2-3 minutes and then it just uploads to WordPress.

    It doesn’t give me an error either. It’s the “async-upload.php” that tries but doesn’t work.

    I have got it working on my local environment using MAMP but am experiencing the problem on a live server.

    Any help would be appreciated.

    Thanks!

    https://wordpress.org/plugins/amazon-s3-and-cloudfront/

Viewing 8 replies - 1 through 8 (of 8 total)
  • ppops

    (@ppops)

    Some more information…..

    I have tried with a completely new site with just a standard fresh install of WordPress and the same thing happens. It works on my local machine but when trying exactly the same thing on a live server, it fails.

    No other plugins are installed. I tried with a new bucket.

    Both local and live running PHP 5.5.

    A5hleyRich

    (@a5hleyrich)

    Please can you provide the ‘Diagnostic Info’ found under the ‘Support’ tab?

    ppops

    (@ppops)

    Thanks. Here it is:

    site_url(): http://volkswagendealerships.net
    home_url(): http://volkswagendealerships.net
    Database Name: volksdea_volks
    Table Prefix: wp_
    WordPress: 4.2.2 Multisite
    Web Server: Apache
    PHP: 5.5.25
    MySQL: 5.5.42-cll
    ext/mysqli: yes
    WP Memory Limit: 64M
    Blocked External HTTP Requests: None
    WP Locale: en_AU
    Debug Mode: Yes
    WP Max Upload Size: 1 MB
    PHP Time Limit: 30
    PHP Error Log: /home/volksdealer/public_html/wp-content/debug.log
    fsockopen: Enabled
    OpenSSL: OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
    cURL: Enabled
    Zlib Compression: Enabled
    
    Bucket: volkswagen-dealers
    Region: ap-southeast-2
    Copy Files to S3: On
    Rewrite File URLs: On
    
    URL Preview: http://s3-ap-southeast-2.amazonaws.com/volkswagen-dealers/wp-content/uploads/2015/07/10103755/photo.jpg
    
    Domain: path
    Enable Path: On
    Custom Path: wp-content/uploads/
    Use Year/Month: On
    SSL: request
    Remove Files From Server: On
    Object Versioning: On
    Far Future Expiration Header: Off
    Copy HiDPI (@2x) Images: On
    
    Active Plugins:
    Advanced Custom Fields: Options Page (v1.2.0) by Elliot Condon
    Advanced Custom Fields: Repeater Field (v1.1.1) by Elliot Condon
    Advanced Custom Fields (v4.4.2) by Elliot Condon
    WP Offload S3 (v0.9) by Brad Touesnard
    Amazon Web Services (v0.3) by Brad Touesnard
    Contact Form 7 - Dynamic Text Extension (v1.2) by Chris Mavricos, SevenSpark
    Contact Form 7 (v4.2.1) by Takayuki Miyoshi
    Hubink Banners (v0.1) by Sanjay Hadiya (Hubink)
    Hubink Tiles (v0.1) by Paul Amato (Hubink)
    Widget Logic (v0.57) by Alan Trewartha
    WordPress Importer (v0.6.1) by wordpressdotorg
    Iain Poulson

    (@polevaultweb)

    Could you edit your wp-config.php file to replace this line –

    define( ‘WP_DEBUG’, false );

    With these lines –

    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_LOG’, true);
    define(‘WP_DEBUG_DISPLAY’, false);

    This means that any errors are logged to `/wp-content/debug.log’, because some errors are not visible on screen.

    More details about that at http://codex.wordpress.org/Editing_wp-config.php#Debug

    ppops

    (@ppops)

    OK looks like we are getting somewhere! Thanks.
    I’m getting this:

    [12-Jul-2015 23:16:28 UTC] Error uploading /home/volksdealer/public_html/wp-content/uploads/2015/07/performance.jpg to S3: Your socket connection to the server was not read from or written to within the timeout period. Idle connections will be closed.

    ppops

    (@ppops)

    Can someone please help with the above error?

    Cheers.

    A5hleyRich

    (@a5hleyrich)

    It’s likely that this is due to a server configuration issue. Can you try securely copying a file from the server in question to another server? The scp command will be the one to try.

    http://unixhelp.ed.ac.uk/CGI/man-cgi?scp+1

    This will rule out any issues with WordPress and the Amazon SDK.

    ppops

    (@ppops)

    I tried and didn’t didn’t have a problem using the scp command to copy files from and to the server.

    Any other suggestions?

    Thanks.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problems uploading to s3’ is closed to new replies.