Support » Installing WordPress » problems uploading 2.2

  • Just when I am about to finish and upload, I get an error message telling me ‘Append/Restart not pemitted, try again.’ What does this mean? It loaded up all the files and said I had completed all 2.8 MB of the upload, and only tells me this at the very end. I have tried deleting out the WordPress files from my server and deleted the database and created a new one. Yet I still get this message.

    All the WordPress files seem to show up on my file manager, so what does this all mean?

    So after the error message I went ahead and checked the admin/install/php page and I got a bunch of confusing messages about username and password. It did give me a password though, and then a link to the wp.login.php page.

    This page looks like a bunch of php gibberish. What is it supposed to look like? Is there a screeenshot of this somewhere? What, ideally, am I supposed to do on this page?

    Whatever the case, it does not seem like I have fully installed WordPress. I thought the five minute install was supposed to take five minutes. I have been at this for almost five hours. And yes, I did alter my config.php file appropriately.

    I need to have this done asap. Any help would rock!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Here is a an update and more detail. It seems now that I have succesfully uploaded WordPress. Then I open the Install.php link. I get this:

    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn’t work for all server setups. The safest way is to manually create the file.”, “WordPress › Error”); } require_once(‘../wp-config.php’); require_once(‘./upgrade-functions.php’); if (isset($_GET[‘step’])) $step = $_GET[‘step’]; else $step = 0; header( ‘Content-Type: text/html; charset=utf-8’ ); ?> > text_direction) ) : ?>
    ‘.__(‘Already Installed’).’

    ‘.__(‘You appear to have already installed WordPress. To reinstall please clear your old database tables first.’).’
    ‘); switch($step) { case 0: ?>

    ReadMe documentation at your leisure.’), ‘../readme.html’); ?>

    THEN I get two empty text boxes followed by what looks to be a button with:
    <?php _e(‘Continue to Second Step >>’); ?>


    ERROR: please type your e-mail address”)); } else if (!is_email($admin_email)) { die(__(“ERROR: the e-mail address isn’t correct”)); } ?>

    log in with the username “admin” and password “XXX”.’), ‘../wp-login.php’, $password); ?>

    Note that password carefully! It is a random password that was generated just for you. If you lose it, you will have to delete the tables from the database yourself, and re-install WordPress. So to review:’); ?>

    wp-login.php (THIS IS A LINK)

    I XX’ED OUT THE PASSWORD ABOVE. When I click on the login.php link above I get even crazier stuff. Says the email was wrong, but I have no idea what email they are referring to. Was this some email used to set up the domain on the server being used? If so, I did not set it up, and am trying to install WordPress on a subdomain of a site that is not live yet. But I think my problem occurs before this.

    Again, I have a wp-config.php file that has been accurately altered and saved. Any possible help as to what this all means?

    Who is your host?

    It might be that PHP is not configured (or configured properly).

    You are uploading your files via FTP as ASCII (not binary), correct?

    I am using Cyberduck, and the options are FTP, FTP-SSL, and SFTP. I see nothing about binary or ASCII. How do I check that? The PHP version of the host is 5.0.4.

    I noticed another post had questions about getting a error message about an incorrect email address. Is this the same thing? Should I enter:

    error_reporting(E_ALL); ini_set(‘display_errors’, 1);

    in the config.php file as you previously suggested and then see what happens?

    If you are talking about this thread, then realize the solution as explained by whooami was to try using WordPress 2.0.10.

    See if your host can upgrade PHP or you can use PHP 4.x.

    But yes it would be interesting to see what errors you are getting.

    alright, i added the code in the config file and loaded it back up and then checked my install.php link and i got the same message as before. did i do something wrong?

    and yes, the was the post to which i was referring.

    Please consider giving a shot at installing for you.

    unfortunately, i cannot. this is a contract i am working on for a professional site.

    so should i try using 2.0.10?

    Can’t hurt.

    any other suggestions?

    for instance, i did not get an error report when i added the php code to my config file. i sure hope there is a reasonable explanation for all of this, such as my stupidity. are there screenshots of what is supposed to happen when you open the install.php page, or the login.php page after that?

    Okay, I tried WP 2.0.10 and its even worse. I get even more code showing up on the Install.php page and the Login page. Is this a weird browser issue? I am using Firefox on a MAC OSX. In Safari the whole page is coding. I do not have IE.

    Am I supposed to copy the whole link for the Install.php and paste that in my browser? That is all I am supposed to do to start the installation process yes? Is there a trick I am not doing?

    It is still saying it needs a config.php file, but I changed that appropriately. I edited it in TextEdit and when I saved it, put .php at the end. The php shows up as an extension on the file name, but it saves as Western MAC OS. Should I save it as Unicode with a .php extension?

    I am looking for easy answers here. Help!




    this is a contract i am working on for a professional site.

    youre being paid? hmm.

    I dont think editing files and uploading in a mac environment is as hard as you make it sound — there are sure alot of ppl on here that manage these simple tasks.

    That said, why dont you make sure wherever you are being paid??? to install this actually has PHP available.

    After you have done that much, make sure you have uploaded the files correctly. text files (thats PHP, by the way) get uploaded in ascii mode. ANY decent ftp client provides an option to switch between binary and ascii.

    Maybe you need to get a better ftp client (you ARE being paid, right?) if yours doesnt let you toggle or atleast confirm thats how they’re uploaded.

    Im sorry for harping on the “paid” but but its really tough to read a thread like this and honestly, harder still to offer help given that assumed admission.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘problems uploading 2.2’ is closed to new replies.