Support » Installing WordPress » Problems Upgrading From WordPress 2.6.3 to 2.7

Viewing 15 replies - 1 through 15 (of 20 total)
  • I had this exact same problem. I talked to my host and they fixed it. When I asked them how, they said “There was memory-cache stuck open which was cleared and that resolved the issue.” So maybe ask your host to see if they can fix that?

    I contacted my host and they said that everything seems to be fine their end…

    Thanks anyway though. 🙂

    clear site cookies
    clear browser cache
    clear any caching plugin folders

    Done. Same problem keeps happening. I’m stuck in this loop…

    Anyone?… 🙁

    I’ve tried downloading back to 2.6.3 but it still keeps making me do this infinite loop of installing.

    This sucks! Anyone know how to contact WordPress directly?

    You didn’t mention how you were doing your upgrade? Did you do it manually or with WP Automatic Upgrade Plugin? I upgraded 8 sites from 2.6.5 to 2.7 and on the first 3, I used the WPAU with mixed results and lots of errors. Each time I managed to get into the new admin for 2.7 and after making sure the WPAU plugin was deactivated, I used the new built in core upgrade routine and reinstalled 2.7. which fixed the issues. Apparently WPAU doesn’t upload all the new files that 2.7 needs.

    On the last 5 sites, I did a manual upgrade on each and have had zero issues or errors as a result.

    I’m using manual upgrade – upload and edit the files myself. As far as I can tell I’ve done everything right.

    I’ve entered my database information into the new 2.7 config file, is there anything else obvious I may have forgotten to do?

    P.s. Thanks for the reply. 🙂

    I’m still confused about what you are doing.

    I’m assuming you are upgrading from 2.6.3 to 2.7. Are you running your WP from your root directory or from a “wordpress (or other named) directory” in your root?

    If from the root, and you ftp all the new 2.7 files to your server and overwrite the old 2.6.3 files, you wouldn’t do an install, that is for only first time use, you would do an upgrade. ../wp-admin/upgrade.php.

    If you are running from a “wordpress directory” in your root, make a new folder on your computer, name it “wordpress2 (or other named)”, load all the new 2.7 files into it. Then add all your WP-Content files, theme, plugins, uploads, plus your old config file and upload to server. Then switch names of the folders on the server so the newly uploaded folder in now just “wordpress (or other named)”. Then go to ../wp-admin/upgrade.php. and all should be fine. I use this method so if I screw something up I can just switch folder names and be back to the previous version. Going to ../wp-admin/upgrade.php then will downgrade your database to the older version as well.

    Okay, I am upgrading from 2.6.3 to 2.7 – and I am running it from my root directory (using FileZilla to manually update my files).

    I didn’t know I had to use an update, so the very first time after I uploaded all the new 2.7 files, I used the install option. I’ve tried using ‘/wp-admin/upgrade.php’ not but all I get is:

    No Upgrade Required

    Your WordPress database is already up-to-date!“

    Once again, I’m now stuck with the loop. I tried re-uploading my files and using the upgrade.php link again but I get the same up-to-date page.

    Am I screwed?…

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Link please? That might help see what’s going on.

    Also before you upgraded did you disable all of your plugins?

    My website is:

    I didn’t disable the plugins the first time, but did the second. Would that make a difference?

    Sorry to bump, but I’m still stuck! 🙁

    I see the install page at that link to name the blog and enter an email…is that what you are seeing?

    Yeah, and I can’t get out of that. Every time I attempt it just sends me back to that page after saying it’s successfully installed?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Problems Upgrading From WordPress 2.6.3 to 2.7’ is closed to new replies.