WordPress.org

Forums

[resolved] Problems upgrading from 1.1 beta. (3 posts)

  1. Tancred
    Member
    Posted 10 years ago #

    Hi
    I used b2 for a couple of years and when wordpress 1.1 beta came out I made the jump over. I have been totally slack about upgrading but I'm trying to now. The wiki talkes about upgrading from version 1.2 to 1.5 so I downloaded 1.2 from sourceforge and tried that. My install of 1.2 (pointed at the old database) now says -

    Database error: [Unknown column 'post_date_gmt' in 'where clause']
    SELECT DISTINCT * FROM b2posts WHERE 1=1 AND post_date_gmt <= '2005-07-11 05:45:59' AND (post_status = "publish") GROUP BY b2posts.

    What steps did I take? I backed everything up, deleted all the files, installed 1.2, fixed wp-config.php, logged in and fixed the permalinks. Tried the same with 1.5 and got a very similar error message.

    Can anyone offer advice?

    Cheers

  2. pericat
    Member
    Posted 10 years ago #

    Sounds like you may have not run upgrade.php when you went to 1.2. It's in the wp-admin subfolder. In both 1.2 and 1.5, it makes changes to your existing WP tables.

  3. Tancred
    Member
    Posted 10 years ago #

    Good point, I was running install not upgrade. D'oh

    I tried to upgrade straight to 1.5 and got a bunch of error messages -
    Warning: Invalid argument supplied for foreach() in /home/.quorum/tancred/tancred.net/blog/wp-admin/upgrade-functions.php on line 30

    Warning: Invalid argument supplied for foreach() in /home/.quorum/tancred/tancred.net/blog/wp-admin/upgrade-functions.php on line 88

    Warning: Invalid argument supplied for foreach() in /home/.quorum/tancred/tancred.net/blog/wp-admin/upgrade-functions.php on line 96
    Step 1

    So I rolled back to 1.1beta and upgraded to 1.2.1

    This worked - thank :) I'm off to go to 1.5.x

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags