Support » Plugin: MetaSlider » Problems to save pictures

  • Resolved archoin

    (@archoin)


    hi,

    I run a multiside wordpress installation with Metaslider.
    I have updated to Version 3.14.0, but now I cannot save any new slides or drag slides. The Save Buton runs and runs, but nothing chahnge. What can I do?

    greetz
    Carsten

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi @archoin

    Do you see any errors in the browser’s developer tools console?

    https://updraftplus.com/faqs/how-do-i-open-my-browsers-developer-tools/

    archoin

    (@archoin)

    Yes, I see the following errors:

    /wp-json/metaslider/v1/themes/all?action=ms_get_all_free_themes:1 Failed to load resource: the server responded with a status of 403 ()
    app-3-14-0.js?ver=3.14.0:1 Uncaught (in promise) TypeError: Cannot read property ‘message’ of undefined
    at app-3-14-0.js?ver=3.14.0:1

    What does it mean?

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @archoin

    Can you switch to the network tab and look for the error message there?

    http://prntscr.com/oxp5td

    Yes, the message is:

    {success: true, data: {,…}}
    data: {,…}
    success: true

    But initially, the Cerber plugin did not allow me to load this page.

    I disabled the Cerber plugin. So, now I can save and move the sliders of the metaslider plugin

    Apparently there are conflicts between both plug-ins. How can this be solved so I can run both plugins?

    • This reply was modified 4 months, 4 weeks ago by archoin.
    Plugin Contributor kbatdorf

    (@kbat82)

    Hi,

    If you have an error message with both plugins active, can you share that? The success message doesn’t help much.

    I’m not sure what the Cerber plugin is, but most plugins should not be loading any scripts or styles on our plugin page. You should ask their support why this is happening.

    Hi,

    this is the Plugin, I mean: https://de.wordpress.org/plugins/wp-cerber/

    It is a security Plug-In and this Plug-In blocks parts of your Plug-In, but I will ask the support there, what to do, thanks for your help.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi,

    Our plugin uses the REST api to gather data we use within the plugin. It looks like they disable that.

    MetaSlider will work without the REST api (ie. if you’re on an old WP version) but I’d have to know how they disable it.

    Plugin Contributor kbatdorf

    (@kbat82)

    Hi @archoin,

    The next version of MetaSlider will check a little better for whether the REST API has been disabled or not. WP recommends not disabling it though, and instead adding an auth guard to all endpoints.

    Read more: https://developer.wordpress.org/rest-api/using-the-rest-api/frequently-asked-questions/

    If you have an issue after the next MetaSlider release, I’ll be adding a constant to manually disable REST for MetaSlider as well:

    define('METASLIDER_FORCE_ADMIN_AJAX', true);

    Let me know if you have any questions.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.