Support » Plugin: WP Mobile Menu - The Mobile-Friendly Responsive Menu » Problems since update to 2.7.4

  • Resolved Morphim

    (@morphim)


    Hi there.
    I know you seem to be aware of this.
    I want to start by saying that the free version of this plugin is amazing and I appreciate your time on it. I don’t want to appear ungrateful or demanding so the following is hopefully to help you debug. Having said that, I do need it working the same as version 2.7.3.

    I tried to roll back to 2.7.3 but something wasn’t right with this after already updating to 2.7.4.

    I’m having problems with only the background color overlay appearing when the burger menu is clicked; no actual menu, just the overlay. This is mainly safari on ios but it’s not apparent on all iphones, which is odd. This is when ‘slide out over content’ is used. If i switch to ‘slide out push content’ the menu appears fine and as expected but, if reopened lower down my page (I have menu anchors) the menu appears but is blank; the options are still right back at the top and I have to scroll up the mobile menu to reach them.

    On Firefox in ios, the menu works as expected but doesn’t autoclose on click, which safari does.

    I hope this helps. I’m using the version of the plugin you linked to in another thread here – the one with (5) after the name. I also tried the update version, a fresh install on the repo version and the one just mentioned.

    • This topic was modified 4 months ago by  Morphim.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Rui Guerreiro

    (@takanakui)

    Hi @morphim,

    Thanks for the kind words, can you try this one instead.

    https://www.dropbox.com/s/d05yn05dupkt78y/mobile-menu-free.2.7.4%20%285%29.zip?dl=0

    Also clear the browser cache really well, if something works on a browser and doesn’t on the other it can be a cache issue or something very specific that needs to be fixed.

    Thanks

    • This reply was modified 4 months ago by  Rui Guerreiro. Reason: typo
    Morphim

    (@morphim)

    Have you updated this again since your reply to JakeNZ, as that’s the one I’m using at the moment.
    A total clear of everything did indeed fix the overlay / no menu problem. Thanks for that.

    However, it still doesn’t close on click. I’m sure 2.7.3 did this?

    I’m very grateful of you taking the time to address issues on something you provide freely. I send you a virtual coffee : )

    Plugin Author Rui Guerreiro

    (@takanakui)

    I sent 2 links to JakeNZ, when I replied with the 2nd link at the same time you placed this support topic so it’s better to install the latest version just in case.

    Do you mean close in the icon or in the overlay? What is your site URL?
    If you want to keep it private you can send it to [support AT wpmobilemenu DOT com]

    The click in the overlay doesn’t seem to be working, will also fix that and release an official update during the day.

    Morphim

    (@morphim)

    Hey, Rui.

    Thanks very much for this. Have installed version 2.7.4.1.
    However, the header logo isn’t loading. If i switch to ‘text’ in the header, this appears. Switch back to ‘logo’ and the header is blank.

    Also, the ‘close on click’ still doesn’t work on my anchor links. Is it possible to fix this? What I mean by this is that the menu closes after a menu link is clicked.

    Thanks very much again. I’m sure you’re getting a lot of stress from this. I appreciate your hard work.

    • This reply was modified 4 months ago by  Morphim.
    Morphim

    (@morphim)

    Hi again.
    I’ve rolled back to 2.7.3 and can confirm that the header logo now displays and the slide out menu (over content) does indeed slide back out of site when a menu link is clicked.

    Hopefully this helps you.

    Thanks

    Plugin Author Rui Guerreiro

    (@takanakui)

    @morphim Can you try to upload the logo in the retina logo option using the 2.7.4.1?

    And can you send me the site URL so I can have a look at the CSS?
    If you want to keep it private send me an email to [support AT wpmobilemenu DOT com]

    Plugin Author Rui Guerreiro

    (@takanakui)

    @morphim There was definitely another issue in the retina logo logic.
    I’m about to release the 2.7.4.2 version that fixes this.

    After installing that version purge the cache like in this article below.
    Purge the cache

    Morphim

    (@morphim)

    Hi. Apologies for the delay. I had to move on to something else.

    I did have the same logo in the retina settings, as well as the regular header logo, at the time of my message above.

    However, I think you’ve perhaps sorted this now.

    Thanks again for your time and I’m sorry you’ve had such problems with this.

    Plugin Author Rui Guerreiro

    (@takanakui)

    @morphim I’m glad it’s sorted. Thanks for your words, it happens and I’m around to support all the users.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.