Support » Plugin: Wordfence Security - Firewall & Malware Scan » Problems since update to 7.1.15

  • Resolved ScalarEnt

    (@scalarent)


    Since updating to 7.1.5, I have a number of sites that now return “Critical problems: Scan Time Exceeded”

    Looking into it. These sites have had the scan settings reduced to “limited scan” and the time for this set to 180 seconds (3 minutes).

    I changed setting on a couple fo sites to “standard scan” and “Time limit that a scan can run in seconds” to 900 (15 minutes). It now run longer but I get “Fatal error: Maximum execution time of 30 seconds exceeded in /home/sites/gandertaxservices.co.uk/public_html/wp-content/plugins/wordfence/lib/wordfenceScanner.php on line 235 ”

    Any ideas ?

Viewing 15 replies - 1 through 15 (of 29 total)
  • Thread Starter ScalarEnt

    (@scalarent)

    SAme story on a different site but different error:

    [Oct 16 09:20:23:1539678023.735721:1:error] Fatal error: Maximum execution time of 30 seconds exceeded in /home/sites/charlottewooddance.co.uk/public_html/wp-includes/wp-db.php on line 2794

    Thread Starter ScalarEnt

    (@scalarent)

    Running scan again on same site I get a differnet error:

    [Oct 16 09:25:27:1539678327.644164:1:error] Fatal error: Maximum execution time of 30 seconds exceeded in /home/sites/charlottewooddance.co.uk/public_html/wp-content/plugins/wordfence/lib/wordfenceScanner.php on line 389

    Thread Starter ScalarEnt

    (@scalarent)

    I get similar errrors on “Limited scan”

    Ditto, getting it across multiple sites – even though I change it they all get reset to “limited scan” and a 180 seconds san time, which just errors with Scan Time Exceeded.

    Thread Starter ScalarEnt

    (@scalarent)

    Wordfence updated to new version 7.1.16 ;ast night but still getting fatal error:

    [Oct 17 08:59:44:1539763184.950709:1:error] Fatal error: Maximum execution time of 30 seconds exceeded in /home/sites/charlottewooddance.co.uk/public_html/wp-content/plugins/wordfence/lib/wordfenceScanner.php on line 389

    me too .. getting this across multiple sites

    (note to moderator – I have started my own topic on this, but it hasn’t been replied to)

    Hi @scalarent,
    In the scan log, you should be able to see what is happening right before this error happens. Can you send me the full scan log please and I’ll be happy to have a look. Use the “Email activity log” button and change the email to asa@wordfence.com. Reply back here in the forum when you’ve sent it so I know to go look for it.

    Thanks in advance!

    Thread Starter ScalarEnt

    (@scalarent)

    Hi wfasa,

    I have emailed the full scan log to you as requested.

    If it helps, I have noticed that all my sites having this issue are on Heart Internet or 123-reg hosting. Others on 1&1 hosting seem to be OK.

    Steve

    For what it’s worth, my sites are also with Heart. Other sites with UK2 seem to be okay. Whether this is causality or correlation, who knows.

    @scalarent Heart and 123-reg are both in the same group of companies along with TSO and GoDaddy.

    Thread Starter ScalarEnt

    (@scalarent)

    Thanks @cucocreative – didn’t realise that

    Hi there,
    sorry for not responding sooner. We know at this point that Heart/123-reg are intentionally setting Wordfence scan options automatically to settings that makes the scan break. They set the time limit for scans to 180 seconds which means that all scans on these hosts will stop after 3 minutes, whether they are completed or not. I’ve tried reaching out to them but not heard back. To proceed with this issue you need to reach out to Heart/123-reg and ask them to either stop setting Wordfence scan options, or to set them to something that works.

    @wfasa

    Did just that, this is what Heart say:

    Lately we noticed that something has changed in how WordFence is running the scan process – it is taking much time and is consuming huge amount of resources on the shared servers.

    This forced us to implement some changes on the shared hosting platform to restrict the time for which those scans can run. However, if you change the execution time settings for the WordFence scan in the database of your WordPress, you should be able to run a single scan on demand, but after that our system will trigger and will change the settings again back to 180 seconds. Please keep in mind that adding php.ini won’t affect the execution time limit of the WordFence scans.

    From what I see, the WordFence scans are taking more time in cases when the website is full of content – some files in the wp-content folder and many old post, comments etc. in the database. Because of this I can say it is a good idea to try to optimize the website and remove all old content that is not being used anymore and also to optimize the wordpress database.

    Of course another workaround will be to get a VPS, where you will be able to set the restrictions on your own, but in my opinion the suggestion to try to optimize the whole website first worth trying.

    Thanks @cucocreative,

    Heart sets the scan time limit to 3 minutes. The time it takes for a scan to complete does depend on how many files you have, but it also depends on the servers performance. I don’t think it’s very likely that you’d be able to get a basic scan to complete in 3 minutes on most shared hosting, even if you delete lots of files. A small WordPress site on shared hosting would normally take around 5-15 minutes to scan with the “basic” scan type.

    We haven’t changed anything in the scan recently and you don’t need a VPS to run Wordfence. It’s installed on 2 million sites out there and the majority are on shared hosting plans.

    I’ve tried reaching out to Heart myself but haven’t heard back unfortunately. If you chat to them again, feel free to encourage them to contact me at asa@wordfence.com.

    @wfasa

    I have passed your comment on, hopefully someone will contact you.

    Thread Starter ScalarEnt

    (@scalarent)

    Hi wfasa,

    I totally agree with what you say. Most of my sites having this problem are actually quite small but Heart’s shared servers typically are quite slow most of the time and hence scans take more than 3 minutes.

    Their comment about upgrading to VPS is just not necessary and they seem to be using it as an excuse to get people to upgrade rather than them fixing their slow servers.

    I will also raise this with Heart.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Problems since update to 7.1.15’ is closed to new replies.