Support » Installing WordPress » Problems Setting up a WP Network

  • Resolved hadenp


    Hi, I’m trying to make the installation (WP 3.2) on my development machine support multiple blogs but getting errors.

    I followed the instructions in the ‘Create a Network of WordPress Sites’ document which included the steps listed below. Clearly, tables that WP expects didn’t get created but I have no idea why and now I can’t log in.

    Any help would be greatly appreciated!

    Here’s what I did.
    1) I created a blogs.dir directory at Applications/MAMP/htdocs/blog/wp-content/blogs.dir and made it writable.

    2) Added the following to wp-config.php
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/blog/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘localhost’ );
    define( ‘PATH_CURRENT_SITE’, ‘/blog/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    3) Added the following lines to a new .htaccess file:
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    When I logged in I got a message that ‘One or more database tables are unavailable. The database may need to be repaired.‘ I added define(‘WP_ALLOW_REPAIR’, true); to the wp-config.php.Then I ran the ‘Repair Database’ option and got the following errors:

    wp_1_posts: Table ‘wordpress.wp_1_posts’ doesn’t exist
    wp_1_comments: Table ‘wordpress.wp_1_comments’ doesn’t exist
    wp_1_links: Table ‘wordpress.wp_1_links’ doesn’t exist
    wp_1_options: Table ‘wordpress.wp_1_options’ doesn’t exist
    wp_1_postmeta: Table ‘wordpress.wp_1_postmeta’ doesn’t exist
    wp_1_terms: Table ‘wordpress.wp_1_terms’ doesn’t exist
    wp_1_term_taxonomy: Table ‘wordpress.wp_1_term_taxonomy’ doesn’t exist
    wp_1_term_relationships: Table ‘wordpress.wp_1_term_relationships’ doesn’t exist
    wp_1_commentmeta: Table ‘wordpress.wp_1_commentmeta’ doesn’t exist

Viewing 1 replies (of 1 total)
  • hadenp


    So, converting to multisite was not the pain free operation I’d hoped for. But here’s what I did, which eventually worked for me.

    I backed out the additions to wp-config.php etc to see if I could just view my original blog, which I could.

    Then I started the procedure again, using the instructions. Did this a couple times. At some point, I got an error saying I needed to remove or empty the network db tables, the names for which I found here:

    Went through the procedure again. Still, wasn’t seeing the ‘super admin’ menu that would allow me to switch between blogs.

    Finally, I upgraded to 3.3.1 and that worked.

    Hope this helps someone!

Viewing 1 replies (of 1 total)
  • The topic ‘Problems Setting up a WP Network’ is closed to new replies.