WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Problems setting-up a Network from a fresh install (4 posts)

  1. andymacleod
    Member
    Posted 2 years ago #

    I manually installed WordPress 3.5 in a directory: /wordpress using the instructions on http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    WordPress seemed to be working correctly.

    I then followed the instructions on http://codex.wordpress.org/Create_A_Network to set-up the multisite.

    I can login to /wordpress/wp-admin/ but when I select My Sites > Network Admin > Dashboard I get the "This is somewhat embarrasing, isn't it" page.

    I had a slightly different situation when I tried to use a 1-click installer (SimpleScripts) which my webhost (iPage) offers. Although when I installed WordPress by that route, I could access the Network dashboard and create child sites - although I couldn't access the dashboards for the child sites, and on the front-end, the sites appear without the theme/css...

    I tried installing several times, checking that I had done everything correctly. I tried installing in the root directory as well as subdirectories - same problem. I also referred to the ebook "WordPress Multisite 101" to see if that could throw any light on the situation. I changed the permalink structure a few times to verify that mod_rewrite module was working correctly. It seemed to be.

    I contacted my webhost and asked them if AllowOveride and mod_rewrite were enabled, and they said:

    I'm sorry to know that you are experiencing issue in WordPress. I sincerely apologize for the inconvenience. mod_rewrite is enabled on our platform. Could you please check again? If the issue still persists then please provide us with the exact URL where you are experiencing the issue and the steps to replicate the issue.

    Apart from posting here, I will follow that up with them...

    My root .htaccess folder contains this:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) hermes/bosweb/web164/b1643/ipg.ajmacleod/wordpress/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ hermes/bosweb/web164/b1643/ipg.ajmacleod/wordpress/$2 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    My website is: andymacleod.net

    Any help with this would be greatly appreciated!

    Thanks,

    Andy

  2. andymacleod
    Member
    Posted 2 years ago #

    One more point:

    When enabling multisite, on the Network Setup page, I get a note asking me to check that mod_rewrite is enabled... It seems to work, in that I can change the Permalink structure...

  3. andymacleod
    Member
    Posted 2 years ago #

    I think it is now working! By trial and error and using this post to help: http://wordpress.org/support/topic/fresh-install-subfolder-multisite-infinite-redirect-loop-sub-blog-login

    I reinstalled WordPress 3.5 (again) - this time in the root directory. Followed the usual procedure to set-up multisite, then replaced my .htaccess with the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress
  4. You don't need all that.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    # END WordPress

    The files lines aren't need any more if you have a fresh (from 3.5) install of WP. If you've upgraded Multisite from 3.4 to 3.5, you still need it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.