Support » Plugin: Jetpack by WordPress.com » Problems sending out Emails to email subscribers

  • Web-Pepper

    (@pctevree)


    Hiya, we have this problem sending out Emails to email subscribers.

    Website: http://www.eethetbeter.nl

    Now we found: https://eethetbeter.nl/wp-admin/admin.php?page=jetpack-debugger
    That says “There seems to be a problem with the ability of the site to communicate with Jetpack.”

    We checked:

    – The known issues, none of them seem to apply to this website
    – Disabled all plugins except Jetpack (did not help)
    – The theme, we use DIVI by Elegant themes, i dont think that one is the problem
    – Checked the XMLRPC, seems to work ok

    We checked https://jetpack.com/support/debug/

    – But this gives an “unknown error”

    What can you guys do to help us? How do we get this fixed?

    Kind Regards,
    Ralph

    At the debug mode in the website itself, we get the error-log below:

    
    SELF:
    	Array
    (
        [headers] => Requests_Utility_CaseInsensitiveDictionary Object
            (
                [data:protected] => Array
                    (
                        [server] => nginx
                        [date] => Tue, 20 Sep 2016 06:57:25 GMT
                        [content-type] => text/plain;charset=utf-8
                        [expires] => Wed, 11 Jan 1984 05:00:00 GMT
                        [cache-control] => no-cache, must-revalidate, max-age=60
                        [x-hacker] => Jetpack Test
                        [x-ac] => 3.ams _dfw
                        [strict-transport-security] => max-age=15552000
                    )
    
            )
    
        [body] => {"error":"Unknown Error","error_description":"An unknown error has occurred."}
        [response] => Array
            (
                [code] => 400
                [message] => Bad Request
            )
    
        [cookies] => Array
            (
            )
    
        [filename] => 
        [http_response] => WP_HTTP_Requests_Response Object
            (
                [response:protected] => Requests_Response Object
                    (
                        [body] => {"error":"Unknown Error","error_description":"An unknown error has occurred."}
                        [raw] => HTTP/1.1 400 Bad Request
    Server: nginx
    Date: Tue, 20 Sep 2016 06:57:25 GMT
    Content-Type: text/plain;charset=utf-8
    Transfer-Encoding: chunked
    Connection: close
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=60
    X-hacker: Jetpack Test
    X-ac: 3.ams _dfw
    Strict-Transport-Security: max-age=15552000
    
    {"error":"Unknown Error","error_description":"An unknown error has occurred."}
                        [headers] => Requests_Response_Headers Object
                            (
                                [data:protected] => Array
                                    (
                                        [server] => Array
                                            (
                                                [0] => nginx
                                            )
    
                                        [date] => Array
                                            (
                                                [0] => Tue, 20 Sep 2016 06:57:25 GMT
                                            )
    
                                        [content-type] => Array
                                            (
                                                [0] => text/plain;charset=utf-8
                                            )
    
                                        [expires] => Array
                                            (
                                                [0] => Wed, 11 Jan 1984 05:00:00 GMT
                                            )
    
                                        [cache-control] => Array
                                            (
                                                [0] => no-cache, must-revalidate, max-age=60
                                            )
    
                                        [x-hacker] => Array
                                            (
                                                [0] => Jetpack Test
                                            )
    
                                        [x-ac] => Array
                                            (
                                                [0] => 3.ams _dfw
                                            )
    
                                        [strict-transport-security] => Array
                                            (
                                                [0] => max-age=15552000
                                            )
    
                                    )
    
                            )
    
                        [status_code] => 400
                        [protocol_version] => 1.1
                        [success] => 
                        [redirects] => 0
                        [url] => https://jetpack.wordpress.com/jetpack.testsite/1/?url=https://eethetbeter.nl/xmlrpc.php
                        [history] => Array
                            (
                            )
    
                        [cookies] => Requests_Cookie_Jar Object
                            (
                                [cookies:protected] => Array
                                    (
                                    )
    
                            )
    
                    )
    
                [filename:protected] => 
                [data] => 
                [headers] => 
                [status] => 
            )
    
    )
    
Viewing 9 replies - 1 through 9 (of 9 total)
  • dominiquehurley

    (@dominiquehurley)

    Hi Web-Pepper – I don’t have an answer for you, but I came into the forum to say that it’s now been 2 weeks that my subscribers aren’t getting a notification email when my blog post publishes. Last week, I thought it might be a one-time glitch, but now it’s been 2 weeks. I haven’t changed any settings, but I know that I’ve updated the Jetpack plugin a few times when notified to do so.

    I’m not a techy so can’t provide the kind of info you have, but I”m using the theme Enfold by ThemeForest.

    I’m at http://www.DominiqueHurley.com

    Marc Kranat

    (@marclouis)

    @pctevree Seeing the exact same thing on only one out of a few blogs I manage, what I notice is this one is the only one running nginx.

    The only 400 error, well really a 405 (when i check server logs) is the from the /wp-admin/admin.php?page=jetpack-debugger test on /xmlrpc.php, but that is expected as it is a GET, not a POST, which is what you normally see on that url, i am not sure this is even connected with the subscription emails not going out, as all other requests on /xmlrpc.php respond correctly with a 200.

    @dominiquehurley are you also using nginx?

    sugarsaltmagic

    (@sugarsaltmagic)

    Hi dominiquehurley, I have the exact same issue. My posts haven’t sent for 2 weeks, ever since I updated to 4.3.1. So far the response from Jetpack has been very slow and I’ve had to manually send out my posts by email. I’m using a different theme though, foodiepro by Shay Bocks.

    dominiquehurley

    (@dominiquehurley)

    Hi @marc Kranat – I have no idea if I’m using nginx. I’m not a techy at all. I built my website and manage it on my own (huge accomplishment) through an online course. But we didn’t get very technical. The Enfold theme has an amazing tech team that answered all my questions. But if I had issues with Jetpack, they always asked me to contact them.

    I saw in another thread that someone responded that Jetpack (before they left) acknowledged it was a glitch at their end but never got back to him about fixing it. So hopefully it’s on their to-do list asap.

    KnoxvilleUrbanGuy

    (@knoxvilleurbanguy)

    Same: My email subscriptions are not working properly. I’ve never had a problem before. Subscribers get an email when I post an article. Simple. Not now. I’m hearing from multiple subscribers who aren’t getting it every day (some say Sunday and Wednesday particularly) and other emails trail in hours later. I also tried to subscribe myself and wasn’t allowed to (It said I had succeeded, but I never got the email confirmation and, no, it did not go into a spam folder. Also, I noticed that on the “old stat” page I have over 1100 email subscribers, but the “more stats on WordPress” site says I have just over 1,000. This has always worked so well. What happened? And how can it be fixed?

    MiaMcP

    (@miamcp)

    My notification emails are not going out either.

    Plugin Contributor Ryan Cowles

    (@ryancowles)

    @pctevree: I had a look at your site, and Jetpack seems to be properly connected to WordPress.com at the moment. Have you managed to solve the issue by yourself?

    If not, could you please let me know the exact steps that result in the trouble? Please be sure to include any relevant screenshots and error messages.

    For everyone else in this thread, could you please start your own thread, as per the Forum Welcome?

    https://wordpress.org/support/plugin/jetpack#new-post

    Each of these issues will need to be investigated separately, so having individual threads will allow us to make sure we don’t miss any.

    Thanks all!

    Hello – I haven’t had any emails going to my subscribers for a month now (Nov. 18, 2016). Was contacted by one of my subscribers to let me know they weren’t receiving theirs. Also spoke to a few others and they have confirmed they are not receiving them either. Help, I’m not very technical, so don’t know where to look.
    Thank you for any help you can give.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic 🚀

    @lougagne47 Could you please start your own thread, as per the Forum Welcome?
    https://wordpress.org/support/plugin/jetpack#new-post

    Could you let me know your site URL there, so I can take a closer look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.com/contact-support/

    Thank you!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problems sending out Emails to email subscribers’ is closed to new replies.