WordPress.org

Support

Support » Installation » Problems running wordpress “staging” site.

Problems running wordpress “staging” site.

  • Hi

    I have set up a staging site which is a direct copy of my original site. They are both on two separate FTP’s. In the functions.php file on the copied version i put:

    update_option(‘siteurl’,’http://example.com/blog’);
    update_option(‘home’,’http://example.com/blog’);

    Otherwise it would just throw me back to the URL of my original site and that kind of defies the point of having a “staging” site.

    My problem is this. Everything i change in the back-end of the “copied” version changes in the “original” version as well despite the fact that i have modified the functions.php file. This leads me to think that the files i copied accross from the original site has settings that needs to be changed. I need to keep them seperate for development reasons.

    I’m sorry if this is a bit unclear. Any questions i will try to answer to the best of my ability.

    Any help is greatly appreciated

    Thanks
    Fred

Viewing 2 replies - 1 through 2 (of 2 total)
  • The files have nothing to do with content – that is all stored in the database. So, if you didn’t change the table prefix in wp-config.php, you have both installs accessing the same database tables – not good.

    Samboll you are a genius. I had no idea the settings were stored in the database i thought it was written to setting files upon installation.

    Thanks a lot for your help.

    Fred

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problems running wordpress “staging” site.’ is closed to new replies.
Skip to toolbar