Support » Plugin: Cerber Security & Antispam » Problems porting to laptop (local development)

  • Hi,

    We’ve been using your plug-in for a while on our web site and it’s worked great. However, when I ported the web site to my laptop for local development, things got a little glitchy.

    PROBLEM 1:

    With the WP-Cerber plug-in enabled, I could not log into WordPress on my laptop. The error received was:

    "The requested URL / (hidden URL) was not found on this server"

    I tried to disable the plugin by downloading the wp-cerber-reset.zip, moving the wp-cerber.php plugin to the wp-content/plugins/wp-cerber folder, then attempted to log in via the /wp-login.php script. I received another error:

    "Error thrown"
    Call to undefined function deactivate_plugin()

    PROBLEM 2:

    So I went back to my production site, disabled the WP-CERBER plug-in, then backed up and downloaded the site, re-installing it on my laptop.

    I accessed the site on my laptop as a user. It worked.
    I logged into the site on my laptop as an administrator. It worked.
    I then activated the WP-CERBER plug-in on my laptop. Not working.

    Attempting to access the site (on my laptop) as a user I received only a blank page.
    Then I attempted to log in via the /wp-login.php url, I received the following:

    Error Thrown
    Call to undefined function deactivate_plugins()

    Any clues what I should try?
    Activating WP-CERBER on my desktop isn’t a show-stopper, but I’d like my laptop environment to be as close as possible to my production environment especially for testing.

    Thanks in advance

Viewing 6 replies - 1 through 6 (of 6 total)
  • Well, this is strange.

    I restored the site to my laptop for the 3rd time without WP CERBER enabled. I deleted the plug-in and re-installed it. When activating WP CERBER, I selected a completely different hidden URL value than my live site, let’s call it /custom-admin. I logged off the admin panel to be greeted by the same, “URL not found on this server” message.

    I tried to sign on with /custom-admin, “URL not found on this server”.

    I tried to sign on with /wp-admin, AND IT WORKED even though I had previously logged out. Moreover, I wasn’t challenged for my creds. It was as if I never signed off.

    Does this make sense? So odd…

    Plugin Author Gioni

    (@gioni)

    Hi!

    First of all, the wp-cerber-reset.zip plugin is a kind of disposable piece of software. Once you’ve uploaded it and visit any page of the website (to let it do its job) you have to replace it with the real Cerber plugin. So delete wp-cerber-reset.zip and don’t use it anymore.

    You need to inspect the Apache error log file and the plugin Activity tab for relevant error or warning messages.

    Don’t forget to reset any caching plugin and add a new Custom login URL to the list of pages not to cache.

    Hi –

    Thanks for the reply. I can’t visit any page of the web site once I install the wp-cerber.php file from the wp-cerber-reset.zip file (by the way, only that file was in the zip file, there was no folder as the instructions at https://wordpress.org/support/topic/i-cant-login-im-locked-out-of-my-site/ would indicate.

    Since I am locked out of the administration panel, I cannot disable any caching plugins.

    Here is what I did, step by step, with pass/fail results at each step. The apache access.log and error.log files aren’t providing any help.

    BTW relevant software versions:
    PHP 7.1
    MYSQL 5.7
    Wordpress 4.8.1
    WP-CERBER 5.1

    Step P/F Description
    1 [Pass] Restore the web site without WP-Cerber plug-in active
    2 [Pass] Check: Access the web site as a user
    3 [Pass] Check: Log-in to WordPress back-end using wp-login.php
    4 [Pass] Delete inactive wp-cerber plug-in
    5 [Pass] Check: Access the web site as a user
    6 [Pass] Check: Log-in to WordPress back-end using wp-login.php
    7 [Pass] Using Windows Explorer (file manager), verify wp-cerber folder is not in /wp-plugins folder (it isn’t)
    8 [Pass] Download (via “Add-new” plug-in and activate fresh WP-Cerber plug-in, version 5.1
    9 [Pass] WP Cerber dashboard, change/verify 2 values:
    Custom login UR: http://devsite.com/xyzabc-login
    Disable wp-login.php (checked)
    10 [Pass] Clear all browser history. Close & re-open browser.
    11 [Pass] Check: Access the web site as a user
    12 [Fail] Check: Log-in to WordPress back-end using wp-login.php
    Log-in form appears under URL.
    So, enter credentials anyway.
    Error message: Not Found The requested URL /xyzabc-login/ was not found on this server (404)
    From Apache access.log:
    `127.0.0.1 – – [13/Sep/2017:16:29:54 -0400] “GET /wp-login.php HTTP/1.1” 200 3184
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-includes/js/jquery/jquery.js?ver=1.12.4 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-includes/css/dashicons.min.css?ver=4.8.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-admin/css/forms.min.css?ver=4.8.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-includes/css/buttons.min.css?ver=4.8.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-admin/css/l10n.min.css?ver=4.8.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-admin/css/login.min.css?ver=4.8.1 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:29:55 -0400] “GET /wp-admin/images/wordpress-logo.svg?ver=20131107 HTTP/1.1” 304 –
    127.0.0.1 – – [13/Sep/2017:16:30:17 -0400] “POST /xyzabc-login/ HTTP/1.1” 404 211`
    13 [Fail] Check: Log-in to WordPress back-end using xyzabc-login.php
    Error message: Not Found The requested URL /xyzabc-login/ was not found on this server (404)
    From Apache access.log:
    127.0.0.1 - - [13/Sep/2017:16:28:09 -0400] "GET /xyzabc-login/ HTTP/1.1" 404 211
    —-
    At this point, I’m locked out of the maintenance on my site with no way to access.
    So, following instructions found at https://wordpress.org/support/topic/i-cant-login-im-locked-out-of-my-site/
    —-
    14 [Pass] Download wp-cerber-reset.zip, copy wp-cerber.php to /wp-content/plugins/wp-cerber/
    15 [Fail] Check: Access the web site as a user. Blank screen.
    Apache access.log thinks it was successful:
    127.0.0.1 - - [13/Sep/2017:17:07:38 -0400] "GET / HTTP/1.1" 200 -
    16 [Fail] Check: Log-in to WordPress back-end using wp-login.php
    Error message on the browser, nothing in the Apache logs:
    `Error thrown
    Call to undefined function deactivate_plugins()`

    Any ideas? I’m locked out. The only way for the log in to work is a complete restore. After running the reset, even the front end doesn’t work.

    Thanks

    Plugin Author Gioni

    (@gioni)

    Hi! Sorry, I have no idea what is the cause. Here is what I suppose:

    1. Remove the plugin folder to get access to the web site.
    2. Log in to the web site as usual.
    3. Install Cerber.
    4. Deactivate Custom login URL by emptying the custom login setting field.
    5. Uncheck Block direct access to wp-login.php and return HTTP 404 Not Found Error
    6. Uncheck Immediately block IP after any request to wp-login.php
    7. Enjoy the rest of the features with the default wp-login.php (with no Custom login URL)

    Plugin Author Gioni

    (@gioni)

    @onemist8k How is it going?

    Hi Gioni,

    I had all kinds of problems. I removed the Cerber plug-in altogether, deciding to re-install it when the time comes deploy to production.

    It wasn’t too long before I started having problems elsewhere. There are a lot of configuration settings to tweak when working from a local copy. Just when I thought I found all the settings something else would not work. Apache, PHP, Mysql, WordPress, etc all were installed individually, not from any package. It was impacting my development schedule so I just gave up trying to do this locally choosing instead to develop off a hosted service. I took careful notes when trying the local route, so I may go back to try it again in the future when things aren’t time critical.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.