Support » Multisite » [Resolved] Problems on MultiSite configuration

[Resolved] Problems on MultiSite configuration

  • Hello everyone

    I’m doing the modifications on my dev site to create multiple languages website with different domains on the same server.

    When I did it localy I did step by step like this video http://www.youtube.com/watch?v=ndLEVwBA92w

    And localy I had no problems, only when I had to activate my plugins I runned into that problem with current_user_can that you have to add require_once(“pluggable.php”); at the top of /wp-includes/capabilities.php

    So localy everything was ok no problems at all. Of course I have all permissions on my local files.

    Now this is my problem:
    When I tried to install it on online server I got all steps done even some errors same that I had on my local, and after finishing this, when I create new domain for example fr.dev.mysite.com nothing works…
    I gave it new name and etc and still going to the main dev.mysite.com I can see this by the title and on posts page all my posts of the main site are there.

    Is there any expecifications for DB configuration???
    Because I don’t have full control of my DB what are the need’s for this multi site??? db related.

    At the moment I think I have access to create/insert/alter/select nothing else.

    Is there anything else that I need to add???

    Thiago Cruz

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    Enable wildcard subdomains on the live server.

    Ok im back for more feedback.
    I added wildcards to make it work, but when I did it now I got: Error establishing a database connection.
    When it should use the same info for my website.

    What is going on???

    Thiago Cruz

    Go to subdomain.yoursite.com/wp-admin and tell me what you see?

    I suspect that your sub-site creation is failing by not creating the database tables. That normally happens when the ID you’re using doesn’t have full permissions to the database and can’t create new tables.

    Yes you were right I go this message on wp-admin:

    One or more database tables are unavailable. The database may need to be repaired.

    So I need to add to my subdomains permissions to change DB as well right?
    I will do that and see what happens.


    No, you want the ID listed in your wp-config to be granted FULL permissions to the database. Everything. Ask your host if you need help with that.


    Listed on my wp-config???
    Any extra configuration that I need to enter?

    Because as far as I looked into the foruns never heard anything that I need to add extra stuff else than this:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'dev.mysite.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    And this:
    define('WP_ALLOW_MULTISITE', true);

    Is there anything else that I should add?

    Thiago Cruz

    In your wp-config.php file, there is a SQL Username. This is common to ALL installs, MultiSite or not.


    The ID listed under DB_USER needs to have full permissions to your database (listed under DB_NAME)

    Ok my root user for the server has all permissions.
    And has all permissions for files like 777 for all files and still not working.

    What could possible be the problem????

    Thiago Cruz

    Databases are not files (not in the traditional sense, at least). Setting the file permissions for your WordPress files will not change the way WordPress interacts with the database.

    You will need to make sure the database user has full privileges for the database. You would most likely need to manage these settings through the control panel that your Web host provided you. The control panel item for managing the database will most likely be called something like “MySQL Databases” or “Databases” or “phpMyAdmin”.

    I found the issue

    Buddypress or other plugin was killing the whole update…

    If someone read this… PLEASE while creating new website TURN OFF ALL PLUGINS!!! just in case.

    And only enable them after creating all new websites not after finishing network.

    Thanks for all your help Ipstenu and Andrea

    Thiago Cruz

    Moderator Andrea Rennick


    Customer Care at Copyblogger Media and Studiopress

    When you go to set up a network, there’s a warning on that page that says to turn off your plugins. 😉

    Also? Please don’t use your root ID/Password for your SQL ID/password. It’s just not secure. If they hack into that one wp-config.php file, they have the access to get into your WHOLE site. You don’t want that.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Problems on MultiSite configuration’ is closed to new replies.