Problems logging in after enabling FORCE_SSL_ADMIN. Need help! (7 posts)

  1. voidtrance
    Posted 6 years ago #

    I am using WP 2.9.2 and I just enabled FORCE_SSL_ADMIN for my site. After I enabled the setting, WP correctly started to redirect logins to HTTPS. I was able to bring up the wp-login.php page over SSL.

    However, when I try to login, I get the following error message:

    Error submitting form!
    Please make sure both javascript and cookies are enabled in your browser.
    Use the back button to try again...
    (Note: if this still doesn't help, then refreshing your cache might)

    I've tried two different browsers, wiping the cookies and cached data on both and still, it doesn't work.

    Can anyone help me please?

  2. voidtrance
    Posted 6 years ago #

    Can any one help here? I am sure, I am not the first one who has seen this error.

  3. voidtrance
    Posted 6 years ago #

    After attempting to clear all browser data and restarting the browser, now I am getting this:
    You do not have sufficient permissions to access this page.

    The account that I am using to log in has Administrator capabilities so there is no way that "I do not have sufficient permissions".

    The same account easily logs in when I use HTTP instead of HTTPS.

  4. YellowShark
    Posted 6 years ago #

    got same issue ("error subbmitting form etc..."), but have not used FORCE_SSL_ADMIN on this install. any knowledge about this topic?

  5. michaelnagy
    Posted 6 years ago #

    I'm getting the same error here without using this FORCE-SSL-ADMIN, simply can't login in my own site... :/

  6. Grubbyseismic
    Posted 6 years ago #

    I've made sure that the define('FORCE_SSL_ADMIN', true); statement is before the statement loading/redir' to wp-settings, so I'm assuming it's either my server setup (I do have ssl_module loaded) or that my wp-config is a directory above the rest of the site.

    The error specifically stops at wp-login.php.

    This is the sound of me drowning in sorrow (yeah, it's brew time!)...

  7. martinbenninge
    Posted 5 years ago #

    I had the same problem, after I deactivated Anti-Captcha by filiw (http://wordpress.org/extend/plugins/anti-captcha/) I could login again.

Topic Closed

This topic has been closed to new replies.

About this Topic