WordPress.org

Forums

Types - Custom Fields and Custom Post Types Management
Problems inserting terms in a hierarchical taxonomy (5 posts)

  1. antosha
    Member
    Posted 2 years ago #

    Hi,
    To make it short, I have the exact same problem as described by the user here: http://wordpress.org/support/topic/problems-inserting-terms-in-a-hierarchical-taxonomy

    When I add child terms into one my Parent taxonomy term, the child term magically disappears from the list in the taxonomy admin panel (and doesn't show up on the front-end of my website when I display the list "categories" of my custom taxonomy ).

    However, I am using the Types plugin for creating post types and taxonomies.

    The problem started when I migrated my test site into the live server.

    I updated Types plugin to the newest version, but it still does that.

    Does anyone know how to fix this ?
    Thanks!

    http://wordpress.org/extend/plugins/types/

  2. Caridad Zapatero Contreras
    Member
    Plugin Author

    Posted 2 years ago #

    Types uses built-in WordPress custom post types and taxonomies, so the same WordPress bugs apply here:
    http://core.trac.wordpress.org/ticket/14485

    Have you tried the workaround of deleting the option?

    delete_option($taxonomy . "_children");

  3. antosha
    Member
    Posted 2 years ago #

    Hi, thanks for your answer,
    No, I haven't tried that yey. Where do I put this line of code?

  4. Caridad Zapatero Contreras
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    If your problem is the same, you need to add the line wherever you are adding the terms, just after.

  5. Caridad Zapatero Contreras
    Member
    Plugin Author

    Posted 2 years ago #


Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic