WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Problems after update from 1.6.5.2 to 2.0.5

[Resolved] Problems after update from 1.6.5.2 to 2.0.5

  • Got this error as soon I want to see the WP dashboard after update:

    Fehlerausgabe / Error output:
    Fehler beim Verarbeiten des Skript-Headers / Error parsing script headers:
    WordPress-Datenbank-Fehler Multiple primary key defined fΓΌr Abfrage ALTER TABLE iw_woocommerce_downloadable_product_permissions ADD PRIMARY KEY  (product_id,order_id,order_key,download_id) von require_once('wp-admin/admin.php'), do_action('admin_init'), call_user_func_array, Woocommerce->update, Woocommerce->install, do_install_woocommerce, woocommerce_tables_install, dbDelta

    What am I doing wrong?

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 9 replies - 1 through 9 (of 9 total)
  • There must be something wrong with your database tables. Have you tried checking if the iw_woocommerce_downloadable_product_permissions exists and tried repairing it through an interface like phpMyAdmin?

    Multiple keys per table should be perfectly fine though. If none of the above helps, can you give us more information on what database engine and version you are using?

    hmm… πŸ˜‰
    btw. I restored the old version and all is working perfectly again.

    OK
    Doublechecked the table:

    woocommerce_downloadable_product_permis...
    check
    status
    OK

    Optimized the table:

    woocommerce_downloadable_product_permis...
    optimize
    note
    Table does not support optimize, doing recreate + ..

    Repaired the table:

    woocommerce_downloadable_product_permis...
    repair
    note
    The storage engine for the table doesn't support r...

    Still the same error, when I’m clicking whatever in the dashboard.
    What now?

    What type is that specific table? InnoDB does support optimizing, I just tested it, and is an overal better suit for databases for web applications compared to MyISAM.

    It has been InnoDB. πŸ™‚ What now?

    What error do you get when you manually execute this query on your database:

    ALTER TABLE wp_woocommerce_downloadable_product_permissions ADD PRIMARY KEY ('product_id','order_id','order_key','download_id')

    If that fails (please do give me the error), do this one:

    ALTER TABLE wp_woocommerce_downloadable_product_permissions DROP PRIMARY KEY

    And then do the first one again. Please post all errors you get.

    Both example assume you have wp_ as your table prefix btw.

    OK… I put your lines in phpmyadmin/SQL in the SQL-query box and enter.
    The first failed… error:
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''product_id','order_id','order_key','download_id')' at line 1

    Second: No error

    The first again… the same error:
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''product_id','order_id','order_key','download_id')' at line 1

    MySQL-Server version is: 5.5.29-0ubuntu0.12.04.1vrmd1
    What now?

    This it’s this forum that killed my queries, you should use backticks instead of general quotes in that first query. Try the query like this please.

    btw. just tried your new upgrade 2.0.6.
    Whatever you have done… I haven’t changed anything.
    Now, it works πŸ™‚
    …even if I’m getting the big violett banner with this error:
    Your theme does not declare WooCommerce support – if you encounter layout issues please read our integration guide or choose a WooCommerce theme πŸ™‚

    I don’t care… cannot see any mistakes at the moment.
    Thanks for your good support. Keep on πŸ™‚

    Awesome, glad to hear that. πŸ™‚ Marking this topic as resolved.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Problems after update from 1.6.5.2 to 2.0.5’ is closed to new replies.