Support » Plugin: ZodiacPress » Problems after update

  • Resolved heesea

    (@heesea)



    Hello, and thank you for an excellent plugin!

    I am hoping you can help me with a problem. After updating to 1.5.4, the “Next” button stopped working so that a chart cannot be generated. I tried out a few things hoping to resolve the problem. I added the ZodiacPress Enhanced GeoNames plugin and because my site has an SSL certificate, also purchased GeoNames Premium credits. I also tried reinstalling the plugin, but this didn’t resolve the problem. It may be useful to know that I had updated the plugin to 1.5.3 and received a message that the plugin failed to update but it showed as 1.5.3 anyhow. I did the Pre-Support Self-Check and all items were correct. The plugin was working fine before updating and is working well on my other site after the update. Thank you for any help you may be able to provide!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author isabel104

    (@isabel104)

    Sorry about that. This sounds like a JavaScript conflict. I can try to pinpoint the exact conflict with a link to your site. If you’d rather keep that private, you can submit it here.

    Just to be sure, is the “Next” button is broken while using the Enhanced GeoNames plugin, and also when not using that plugin?

    About the 1.5.3 failed update: That can sometimes happen when the WordPress plugin repository has technical issues.

    Thank you! I’ve sent the link to my page to you. It doesn’t work with or without the Enhanced GeoNames plugin, but that plugin also asks for an update but after the update apparently succeeds, it shows the need to update it again (to the same version).

    Plugin Author isabel104

    (@isabel104)

    Thanks for the link. It seemed to work on your page just fine. I tried it several times in different browsers. Maybe it works for you now, as well (maybe it was a cache issue in which part of your page was still using old files rather than the newly updated files).

    However, there are is a JavaScript error that exists in the background:

    • In the plugin Touchy by Bonfire, on line 133 of the file touchy.js. The error is:

      ReferenceError: retinajs is not defined.

    First I would try this: clear your browser’s cache. If you have a cache plugin in WordPress, try to clear the cache just for that report page (you may not want to clear the cache for your entire site). After clearing the cache, try the form again.

    If the birth report form is still not working, it may be due to that one JavaScript error. Although, I doubt that because it would not explain why the old version of ZodiacPress worked. To test this, you could temporarily deactivate the plugin “Touchy by Bonfire” and try the form again.

    Thank you so much! I only needed to clear the caches on my browsers. So sorry to bother you with this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems after update’ is closed to new replies.