Support » Plugin: Gutenberg » Problems after installing Gutenberg 13.0

  • I don’t know where to ask this question so I am asking it here.

    I am using the following:
    WordPress: Version 5.9.3
    Theme: Child Theme of Blockbase: Version 2.0.33
    Gutenberg: Version 13.0

    Every since I installed Gutenberg 13.0 (which I believe I did on 4/19/2022), I can no longer use (effectively), the full site editor to edit the header and footer. It’s not that I can’t open the editor, but when I do, I get disk thrashing. When I try to use the FSE to edit the header and footer (specifically, it happens when I choose the Editor under Appearances) everything becomes extremely slow. I don’t even have to do anything to make it happen. I can wait for the thrashing to begin. I can’t even get out of it without shutting down the browser.

    If I switch back to the parent theme, Blockbase, I don’t get this problem, but I also don’t get my customizations from the child.

    I have been doing regular updates on both WordPress, Blockbase, and Gutenberg for a few months, and I never had this problem before.

    Before I redo my customization work again, I thought I’d see if I can get any help.

    Any suggestions about what I can do?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Hi jcomanda,
    Just letting you know your not alone. I’m using the 2022 theme and have exactly the same problem. When I updated Gutenberg to 13.0 I wasn’t immediately aware of the problem. Editing posts was fine and lists were positioned better.
    Eventually I wanted to make a minor adjustment to my header, then I came across the problem as you describe it. I rolled back Gutenberg to 12.9 made my adjustments and the updated to 13.0 again.
    I find that when trying to perform full site editing with 13.0 the full content isn’t drawn on the screen, e.g. It takes minutes to draw my site logo if at all.
    I think somewhere in the code there is a request made to the browser to do something it cannot do. I don’t get the impression everyone has the problem. We need an Automattic expert to have the problem so they can work it out.

    Thread Starter jcomanda

    (@jcomanda)

    Thanks for your response.

    Here are some things that I tried.

    Instead of trying to edit the whole site, I edited the header and the footer separately under Template Parts. That worked better, and I didn’t loose any of my customizations.

    I still have the problem when I try to edit the full site, but I don’t bother to try.

    I am less sure about the rest of this, but I did try some of these other solutions.

    I got rid of all my group blocks using Ungroup (as opposed to Remove Group). I think this helped, though I no longer remember for sure. I suspected the Group block might be contributing to it because that’s one of the things that changed with 13.0. I was only using Group blocks as an organizing tool, so it wasn’t a big deal to me.

    I also messed with files on the back end, figuring that since I was using a child theme, I could somehow save off files in the block-template-parts folder for the child and refresh them from the latest version of the theme itself. I can’t tell you anymore what worked and what didn’t, though I did come to suspect that some of the customizations are probably not stored there either but are in the database.

    We are using a “Beta” version of the editor, so what can we expect.

    This is my latest info after more testing.

    First I have now moved onto Gutenberg 13.1.0 but it had just the same issues.
    This morning (before the update) I went into site edit mode again and waited and watched what happened over the next hour. Yes that’s a long time.

    It loads the header but not my site logo at first, but that eventually appears just like everything else. After the first 15mins I have a framework for the first 10 posts on page 1 and the footer. Then it starts to fil in text that normally shows and then the feature images. These are what takes all the hour. If I start clicking on items I can disturb the process. After another 15mins to 30mins I might have about 4 feature images but if I scroll down to where the other 6 should be I get a blank screen until those images appear. If I scroll up the original images have gone again.

    Given sufficient time (about an hour ) I can see Header, Footer, and page 1 with its 10 posts.

    It was beneficial to set the browser zoom to 25% then I could more easily see how much detail was rendered.

    My conclusion is that in some way it all works but something is really slowing down the rendering of the site display. Maybe some action is being performed a multiple of times when it should just be done once. With version 12.9.0 all that same detail is rendered in a thrice.

    I hope someone with more experience than us reads this and helps us out. It will be a big problem if this problem crops up in WordPress 6 in a few weeks.

    Thread Starter jcomanda

    (@jcomanda)

    You are a man of great patience. I tried the latest version of Gutenberg today and was disappointed that the problem is still there. Editing the individual template parts works.

    Here’s hoping somebody who can do something about the problem, sees this conversation.

    I just wanted to add that I am having the same issues. I’ll update if I come up with any kind of resolution. I’m using the 2022 child theme.

    Where can I get 12.9 to see if it works for me as well?

    • This reply was modified 3 months, 1 week ago by kingfish65.
    Thread Starter jcomanda

    (@jcomanda)

    For what it’s worth, the group block doesn’t have anything to do with it. I removed them from the whole site and then put them all back. The problem persisted throughout.

    Should we be trying to get help on GitHub? I couldn’t figure out how to do that.

    This issue on GitHub seems to match:
    https://github.com/WordPress/gutenberg/issues/40357

    Thread Starter jcomanda

    (@jcomanda)

    Thanks for finding it on GitHub. Yes, this is exactly the problem. And it turns out that the thrashing problem is probably tied to situations where there are duplicated navigation blocks (and maybe other things).

    It appears that when you duplicate a navigation block, the copy retains the same reference id as the original and they are linked somewhat like reusable blocks, i.e. changing the menu items on one changes them on the other.

    I have two navigation blocks that I created by building one and then duplicating it. In my case, the fact that they were linked was almost a feature, not a bug. It surprised me, but it didn’t bother me. It actually made it more convenient.

    In any case, I eliminated (temporarily in staging) one of the two navigation blocks and was able to get the thrashing problem to go away.

    I still hope they fix the problem because I’m still using the two navigation blocks in production (and have even restored them in staging).

    In the meantime, I have done extensive editing of the header template part rather than of the full site, and I am able to do it without the thrashing.

    I too have confirmed it to be an issue with the navigation menu. I didn’t think mine was that complicated, but after removing a couple of menus with sub-menus, the problem went away. This issue only appears in full site editing. Template, template parts, page, and post block editing is unaffected.

    I just updated to 6.0-RC1-53342 to test. Unfortunately, the issue is still present.

    In regards to 6.0-RC1-53342, the issue is still there with the Gutenberg plugin activated. Without the plugin activated, the editor behaves normally. Since 6.0 incorporates many of the features from the plugin, it may not be necessary.

    Thread Starter jcomanda

    (@jcomanda)

    Thank you for doing these tests and letting us know.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.