Support » Plugin: Site Kit by Google - Analytics, Search Console, AdSense, Speed » Problems after Domain-Migration

  • Resolved flofas

    (@flofas)


    I had a running installation of the plugin on the website, everything was fine.
    Then I changed the domain for my website from “fizfaz.ch” to “spielgruppe-fizfaz.ch”.

    Everything went fine with the migration and i did a DB find & Replace with a tool “WP Migrate DB.
    Now the website is running fine under the new domain but the G Site Kit Plugin Dashboard only shows “The response is not a valid JSON response.”
    But also tells me that analytics & search console are connected.

    I also deactivated FVM and W3 Total Cache Plugin, did a reinstall of Sitekit but no affect. did this several times.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Hey @flofas ,

    Thanks for opening a support topic.

    As for the change-domain search & replace in the Database is not enough. You need to Signup again by resetting Sit Kit as your new domain is not registered to Site Kit service.

    Note: After resetting Site Kit you’ll lost your previous data.

    Best Regards,

    Thread Starter flofas

    (@flofas)

    Thanks for your answer.
    i did this several times, even deleted site kit completly from the website.

    Everytime i am doing a new install, the problem is the same.

    Plugin Support Abdullah Ramzan

    (@abdullahramzan)

    Thanks for getting back to us so quickly.

    Did you make a try to setup Site Kit in incognito window?

    Let’s do an activity to troubleshoot this issue.

    1. Install and activate the Health Check & Troubleshooting plugin.
    2. Navigate to “Plugins > Health Check & Troubleshooting > Troubleshoot”.
    3. From the same screen click on the “Available Plugins” tab at the top right and then click on the “Enable” option next to “Site Kit by Google”
    4. Attempt to setup Site Kit once more

    You can exit troubleshooting mode afterwards.

    Best Regards,

    Thread Starter flofas

    (@flofas)

    Sorry, also troubleshooting did not help.
    Evrytime i do a new install or setup of the Plugin, it tells me that search console, analytics “connection successful” and that google already has access on my data.
    But the error still exists and i cant use the plugin

    Thread Starter flofas

    (@flofas)

    ersion
    1.28.0
    PHP Version
    ***
    WordPress Version
    5.7
    Reference Site URL
    https://***.ch
    AMP Mode
    No
    Site Status
    Connected through site credentials
    User Status
    Authenticated
    Connected user count
    1
    Active Modules
    Site Verification, Search Console, Analytics, PageSpeed Insights
    Required scopes
    openid: ✅
    https://www.googleapis.com/auth/userinfo.profile: ✅
    https://www.googleapis.com/auth/userinfo.email: ✅
    https://www.googleapis.com/auth/siteverification: ✅
    https://www.googleapis.com/auth/webmasters: ✅
    https://www.googleapis.com/auth/analytics.readonly: ✅
    User Capabilities
    googlesitekit_authenticate: ✅
    googlesitekit_setup: ✅
    googlesitekit_view_posts_insights: ✅
    googlesitekit_view_dashboard: ✅
    googlesitekit_view_module_details: ✅
    googlesitekit_manage_options: ✅
    googlesitekit_publish_posts: ✅
    Features
    serviceSetupV2: ⭕
    storeErrorNotifications: ⭕
    userInput: ⭕
    widgets.dashboard: ⭕
    widgets.pageDashboard: ⭕
    widgets.moduleScreens: ⭕
    Search Console property
    sc-domain:***.ch
    Analytics account ID
    5721****
    Analytics property ID
    UA-5721****
    Analytics view ID
    239****
    Analytics snippet placed
    Yes

    • This reply was modified 1 month, 2 weeks ago by flofas.
    Thread Starter flofas

    (@flofas)

    There was Problem with my Analytics Property. no it is working

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @flofas Glad to hear that things are working now! I’ll mark this topic as resolved, but if you do need anything else, feel free to open a new support topic.

    Please also free to leave a review – we’d love to hear your feedback on the plugin.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.