Support » Fixing WordPress » Problems Adding New Posts/Editing Posts

  • Just a disclaimer: I am not terribly familiar with the ins and outs of WordPress and have just taken over posting on this blog as a part of my job. The individual who was adding posts before me seemed to have no issues in updating the blog; however, I am running into problems adding new posts, and existing posts are showing up looking strange. Basically, when I try to add a post, it will allow me to type in a title, but it will not allow me to click in the box to add the body of the text (just does not respond to my cursor whatsoever). When I go in to edit an existing post, the post shows up in white font, making it only visible when I highlight the text. To the viewer, however, the existing blog posts look fine.

    I am on a MacBook, and have tried with both Safari and Google Chrome browsers and have also had a coworker try on her computer (to no avail).

    Any and all suggestions are much appreciated!

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi


    Forum Moderator

    Have you tried another browser? Another computer?

    Yes, I’ve tried with both Safari and Google Chrome on my MacBook, and my coworker tried on her computer (Safari and Google Chrome as well), and it was doing the same thing each time.



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems Adding New Posts/Editing Posts’ is closed to new replies.