Support » Themes and Templates » [Resolved] [Theme: Melville] Problems Adding Link to "Page" in Footer

[Resolved] [Theme: Melville] Problems Adding Link to "Page" in Footer

  • I am trying to create a link in my footer to the “Disclosure, Privacy & Contact” page I created in WordPress. You can actually see the link at the very bottom of my page here:


    Unfortunately, it keeps coming up as a page “Not Found” when I click on it. I know the page exists. I can put it in the menu and it works. I just don’t want it in the menu. I want it at the very bottom of my site in the footer. Any suggestions? I am very frustrated. 🙁

    Thanks in advance!

Viewing 15 replies - 1 through 15 (of 15 total)
  • paulwpxp


    Font hero

    You have some not url safe character in the href attribute, just remove the link and put the link there again by typing.

    Also, when working with code, do use Notepad or any other text editor program, do not use microsoft words or anything like that.

    I tried that and it didn’t help. I removed the link, saved the file, put the link back in there manually and saved it. 🙁

    I can access the page here:




    Font hero

    Instade of this:
    Disclosure, Privacy, & Contact

    use this:

    Disclosure, Privacy, & Contact

    I tried it and it didn’t work. Now I have the ampersand as “&” and it still hasn’t made a difference. Something is wrong with how the link is being processed, not the text. Next suggestion? 🙂

    I meant as:

    & amp ;

    (without the spaces)



    Font hero

    did you modifiy the original theme’s code ?

    i asked because it looked like there’s something wrong with the escaping url.

    Well, I got the link to work by redirecting it, but I still don’t understand why it didn’t take me to the right page in the first place. 🙁

    Not that I can think of…

    Well, redirecting the link URL is a workaround, so if anyone else can think of how to fix this in a proper manner, please let me know.



    Font hero

    First I thought, it’s the theme feature for user to add the footer link so I suspect there is something wrong in the url escaping but once I took at look at the source code the footer.php must be edited or overriden in child theme to change the link.

    Now the problem is this left to right character

    which can be prevented by using plain text editor (like notepad) to edit code.

    Also, you have the email encrypt script in there too that might – or – might not be the cause.

    The only thing I used to edit the code was the WordPress editor in my dashboard. I know to use a plain text editor like Notepad when I am editing files otherwise.



    Font hero

    This is what I “think” it is.

    The left to right mark was put there by copying from the source (somewhere else outside of notepad and outside of WordPress editor) once it’s there, it’s there but it’s invisible. When you found out the problem and tried to correct the issue, you went right in there in WordPress code editor and backspace and re-type, the left to right character was still there but invisibly hanging at the end.

    So if the above is right, then type the whole thing in notepad and copy from notepad and paste, this will solve the problem.

    Anything else other than this that might cause the problem is either the js to encrypt email right before it or WordPress editor itself is causing this.

    If I were you I would do all the editing of footer.php in notepad and ftp the file to the server, the WordPress editor is not for this kind of job anyway.

    Hmm… I found the answer here:


    I went over the URL with the right arrow key and it paused between the end of the URL and the closing quotation mark. I deleted that invisible character and everything is working without the redirect. Yay! 🙂

    Sounds like you were right. 😉

    Thank you!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] [Theme: Melville] Problems Adding Link to "Page" in Footer’ is closed to new replies.