Support » Fixing WordPress » Problems activating Akismet

  • Hello all,

    I am having troubles activating Akismet on one of my blogs, http://creativeforum.org

    In the admin view there is a notice that says:

    “Akismet is not active. You must enter your WordPress.com API key for it to work.”

    When I go to enter the API key on the Akismet config page it has a read warning that says:

    “Your key appears invalid. Double-check it.”

    So, I re-enter my key and click the “Update API Key” button, and then it says “Are you sure you want to do this?” so I click the button that says “Yes”.

    All looks fine (i.e. the Akismet warning has gone), until I browse to another page in the admin interface, at which point the warning “Akismet is not active. You must enter your WordPress.com API key for it to work.” re-appears.

    I’ve no idea what is stopping it from working. It cannot be that the server doesn’t have ‘fopen’ working properly, because Akismet is working fine on other blogs on the same server, eg. http://shorno.net

    I also tried temporarily changing the akismet.php file to 777, but that didn’t work either.

    Any idea what to try next?

    Many thanks,

    Josef.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Try clearing your wordpress cache. Find the cache directory under wp-content (I think) and just delete everything in there. Might want to do this again right after entering the key and saving it.

    hmz, I don’t seem to have a cache directory

    There is a cache.php file in wp-includes, but no directory anywhere I can see.

    Also, looking in the admin interface I can’t see anywhere to enable of disable caching. Am I going blind?

    Cheers,

    Josef

    I reckon that maybe all my permissions need changing or something?

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Well, if there’s no cache then it won’t hurt anything, but the object cache is also clearly not the cause of your problem. Hmm. I dunno, maybe clear your browser cache or something. Or just keep retrying until it works. Sorry, I got nothing. 🙁

    Poke around at akismet.com. Check the FAQ? If nothing else, there’s a help email address somewhere around there.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problems activating Akismet’ is closed to new replies.