Support » Theme: Zoom Lite » Problems about use font awesome icons in primary menu

  • Resolved x1a09i

    (@x1a09i)


    Hi,

    This is a great theme and I’m really love to use it.But there has been a problem since I tried to use some font awesome icons to decorate my primary menu.(the element id is “zoom_nav”)

    In WordPress, I tried to set one of my menu’s navigation label just like below:

    <i class="fa fa-home" aria-hidden="true"></i> Home

    But that icon didn’t appear, And when I checked the source code of the pages,
    the html code appeared as follows:

    <a href=/*my site url*/><span><i></i>Home</span></a></li>

    So, it seems like that contents inside the <i> tag has just lost.But I can’t find the reason.

    But font awesome icons just work fine when I use it to another area, such as my post area.

    Need a Help…

    Thank You!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Theme Author GhozyLab

    (@ghozylab)

    @x1a09i

    Please try to edit theme-functions.php in /wp-content/themes/zoom-lite/inc/ see line: 422, you will find the following code:

    		'label' => array(
    			'for' => array(),
    			'class' => array(),
    		),

    Just add this code after code above:

    
    		'i' => array(
    			'aria-hidden' => array(),
    			'class' => array(),
    		),

    But, if you cannot do that you need to wait until we release the new version to fix this issue in several days.

    Hi, @ghozylab

    Thanks a lot,
    Those code solved my problem perfectly!

    Theme Author GhozyLab

    (@ghozylab)

    @all

    UPDATE:

    When using theme version 1.0.0.41 and above, you can easily go to Theme Customize > Menus > Menu Location & Position > and enable Add Home Button option to show home button with ICON, you also can change the default HOME text from there.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems about use font awesome icons in primary menu’ is closed to new replies.