WordPress.org

Forums

Problem:Only 1st Post Title link to Single Post (4 posts)

  1. megmuzz
    Member
    Posted 4 years ago #

    This is totally weird.

    The post title link does not work in safari with THREE exceptions:
    1. only in safari
    2. only on the newest post. So if add a new post, the title works for the last post, but not the new post.
    3. a untitled window opens

    Here's what you may need to know:

    - I've turned on custom permalinks
    - I've Inserted a slidedeck into the content area:
    -in the header.php file, in page div
    -in it's own sub-div of page div

    NOTE: still doesn't work if I remove the div with the slidedeck -only in safari
    NOTE: client wants slide deck just above posts, in between ad areas

    -Scrolling over title links shows the proper single post target in the status bar of safari browser

    I'm stumped.

    Thanks in advance, and I sure hope I can figure a resolution. I'm thinking about removing some of the other things I did cosmetically and replacing with fresh theme files maybe. But that entails a lot of work.

  2. Can you please provide a link to your site?

  3. megmuzz
    Member
    Posted 4 years ago #

    Ok, it's:

    welovethefans.com

    Disclaimer: This is a template he asked me to modify. I'm not into hip-hop or pop culture or any of the distasteful (though safe) material he has on his site. Anyway, I'm just doing the job and trying to help the guy out.

    Many thanks.

  4. megmuzz
    Member
    Posted 4 years ago #

    !!!UPDATE!!! But I'm still a bit lost...

    Looking at the site through google developer tools, It seems there are multiple hrefs in the content area:

    -One a href directly under the "content" div
    -One a href directly under "entry" div
    -Two a href's under the first post (unnecessary href followed by the correct href)

    At this point, I'm unsure how to get rid of those, as none of those are visible in the post editor, and I don't know where I can find these groups of code in the .php files.

    Please, someone help?

Topic Closed

This topic has been closed to new replies.

About this Topic