Support » Plugin: wpShopGermany Free » Probleme beim Upgrade auf 4

  • Ich habe in meinem Shop die 3.11.3 laufen. Ein direktes Upgraden ist nicht möglich, da bekomme ich einen Datenbankfehler. Die Tabelle wp_wpsg_versandzonen existiere nicht. Deaktivieren, manuell updaten auf 4.0.5 und dann aktivieren geht, aber das Backend sieht ziemlich zerschossen aus und es scheinen Inhalte zu fehlen.

    Eine Anleitung zum Upgrade ist nicht zu finden. Es gibt nur einen Artikel von der Standardversion 3 auf 4. Das darin beschriebene Datenbank-Update findet nicht statt (bzw. wird die Meldung nicht ausgegeben).

    Alles in allem ziemlich frustrierend. Daher bin ich jetzt erst einmal zurück auf die 3.11.3.

    Was ich ebenfalls merkwürdig finden: Der Rat auf die letzte 3er Version zu gehen ist ziemlich schwer umzusetzen, wenn die 3er Versionen hier auf WordPress.org nicht mehr existieren. Die letzte Version im SVN-Repo ist 4.0.0.

    Bin über jede Hilfe dankbar, wie ich die Site auf die aktuelle Version bekomme …

    Beste Grüße
    Torsten

Viewing 5 replies - 31 through 35 (of 35 total)
  • Seit drei Wochen ein kaputter Shop und keine Lösung in Sicht. Das war eine riesige Fehlentscheidung auf die 4er zu wechseln. 🙁

    Plugin Author maennchen1.de

    (@maennchen1de)

    Aktuell wurde noch nichts “Kaputtes” am Shop gefunden. Deine Testbestellungen waren bisher mit unvollständigen Daten gefüllt, die für die Zahlungsart und damit einem erfolgreichen Bestellabschluss benötigt werden.

    Laut PayPal ist für Deutschland tatsächlich der Postal Code erforderlich.

    In einem Bestellprotokoll mit vielen, vielen Zeilen aus der Fehlerbeschreibung “The combination of country and city is invalid” herauszulesen, dass eine vollständige Adresse (Straße, Ort, PLZ) *benötigt* wird ist irrwitzig. Warum kann ich das so konfigurieren, wenn es nicht funktioniert? Warum bekomme ich keine Fehlermeldung, die mir klarer sagt, was eigentlich gerade schief läuft und wie ich es fixen kann.

    Wenn dann noch ein Fehler auftaucht wie …
    Warning: Invalid argument supplied for foreach() in /wp-content/plugins/wpshopgermany-free/controller/wpsg_AdminController.class.php on line 1471
    … vermute ich ja auch eher einen Programmfehler.

    Und noch etwas:
    Ich kann die Anrede zwar auf “Nicht anzeigen” stellen, aber in der Zusammenfassung steht die Standardanrede und da kann ich nur zwischen den Werten wählen die ich eingetragen habe. Ich kann es nicht abwählen. Und ohne Auswahlmöglichkeit steht dann immer der erste Wert dort. :/

    Die Bestellbestätigung geht jetzt durch, da alle Adressfelder als erforderlich markiert sind. Ich bekomme die Bestellbestätigung vom Shop und von PayPal, aber kein Downloadlink. Das ist jetzt die Vollkatastrophe. Geld wird angewiesen, aber das Produkt geht nicht raus. 🙁

    Woran kann das jetzt liegen?

    Im Bestellprokoll und Fehlerprotokoll werden keine Fehler angezeigt.

    Gruß, Torsten

    Plugin Author maennchen1.de

    (@maennchen1de)

    Dein Text hast du 1:1 in unserem Forum, indem wir kostenfreien technischen Support leisten, gepostet. Es wäre schön, wenn die Problemfindung auch weiterhin im Supportforum stattfindet und nicht alles doppelt gepostet werden muss.

    Ich zitiere einmal die ersten 15 Zeilen des ersten Bestellprotokolleintrages in deiner Testbestellung:

    Array
    (
        [name] => VALIDATION_ERROR
        [details] => Array
            (
                [0] => Array
                    (
                        [field] => payer.payer_info.billing_address
                        [issue] => <strong>The combination of country and city is invalid</strong>
                    )
    
            )
    
        [message] => Invalid request - see details
        [information_link] => https://developer.paypal.com/docs/api/payments/#errors
        [debug_id] => 4ae5a9142091
    )

    Der Link wird verschickt, sobald Paypal die Zahlung bestätigt und der Bestellstatus auf akzeptiert gesetzt ist. Deine letzte und einzige Testbestellung am heutigen Tag hat den Status “Eingegangen”.

    Warum der Wechsel zu eurem Forum notwendig ist, wenn wir hier gestartet haben, verstehe ich zwar nicht, aber dann halt nur dort weiter:
    https://forum.maennchen1.de/viewtopic.php?p=55443

    Gruß, Torsten

Viewing 5 replies - 31 through 35 (of 35 total)
  • The topic ‘Probleme beim Upgrade auf 4’ is closed to new replies.