Support » Plugin: Cielo WooCommerce - Solução Webservice » Problema com SSL

  • Resolved diogenesjup

    (@diogenesjup)


    Ao tentar salvar as configurações no WooCommerce (colocando Chave de afiliação e Número de afiliação) aparece uma mensagem dizendo: “Cielo WooCommerce desabilitado: Um certificado SSL é necessário para utilizar a Solução Webservice. Por favor, verifique se um certificado esta instalado no seu servidor”.
    A principio imaginei que poderia ser um problema do meu certificado SSL ou versão do TLS (tem tópicos aqui no suporte sobre isso). Mas mesmo testando todas as opções e verificações (meu certificado e TLS estão ok como pode ser visto no link https://www.ssllabs.com/ssltest/analyze.html?d=www.correcotiakids.com.br).
    Nos logs também não tem nada a respeito.
    Alguém pode me dar uma luz?

Viewing 15 replies - 1 through 15 (of 44 total)
  • estou com o mesmo problema

    Mesmo problema aqui, a opção de pagamento não aparece no checkout.

    Encontrei aqui a solução,
    a opção pra forçar ssl no checkout não aparece no Woocommerce quando o endereço do Site já está com SSL. Então pra marcar a opção é preciso acessar a página wp-admin/options.php, dar um Ctrl+F pra buscar o campo “woocommerce_force_ssl_checkout” e mudar o valor para ‘yes’.
    Com isso o pagamento já deve aparecer no checkout

    @digo1994 @diogenesjup

    ssesportes

    (@ssesportes)

    Estou com o mesmo problema, até pensei que poderia ser o fato de não ter instalado o certificado SLL fornecido pela Cielo. Para conseguir alterar o wp-admin/options.php, pode me informar se isso seria dentro do servidor ou dentro do plug-in? Pois estou procurando em ambos e não encontro. Fico no aguardo.

    diogenesjup

    (@diogenesjup)

    Problema resolvido!!!
    Fiz o que o que o @jlugros falou e funcionou!!
    É só acessar wp-admin/options.php, dar um Ctrl+F pra buscar o campo “woocommerce_force_ssl_checkout” e mudar o valor para ‘yes’.

    AGORA SIM!
    Obrigado pessoal

    ssesportes

    (@ssesportes)

    Alguém consegue me informar se o wp-admin/options.php é do servidor, pois não encontro woocommerce_force_ssl_checkout dentro dele.

    diogenesjup

    (@diogenesjup)

    @ssesportes é uma URL
    Quando você acessar o seu painel e tiver logado como ADM,
    coloque: nomedoseudominio.com.brwp-admin/options.php
    E ai na página a seguir, procure pela opção citada e altere o valor para “yes”

    ssesportes

    (@ssesportes)

    Encontrei porém não estou conseguindo alterar, quando mudo para yes e salvo quando retorno continua com o valor “no”

    diogenesjup

    (@diogenesjup)

    @ssesportes ai nesse caso, o problema não é mais nesse plugin (Cielo), ou é o seu WooCommerce, ou seu WordPress (com alguma diretiva sobreescrevendo esse valor no functions.php ou no wp-config.php)

    ssesportes

    (@ssesportes)

    Irei dar uma olhando no forum e ver se encontro algo parecido, muito obrigado pela ajuda.

    brbazzoni

    (@brbazzoni)

    @ssesportes , estava tendo esse mesmo problema mas alterei direto no BD e resolveu.

    ssesportes

    (@ssesportes)

    Irei tentar alterar e aviso se der certo.

    ssesportes

    (@ssesportes)

    @brbazzoni sabe me informar aonde você alterou isso no banco de dados? Pois estou no phpmyadmin e não estou encontrando nada referente.

    brbazzoni

    (@brbazzoni)

    Abri a tabela do wp_options, pesquisei nas linhas por SSL, no meu caso coloquei para 500 linhas e apareceu a linha do woocommerce_force_ssl_checkout, consegui salvar o pagamento sem erros. Só não estou conseguindo aprovar a compra pelo site ainda.

    • This reply was modified 3 months ago by brbazzoni.

    Eu encontrei porém altero e não muda nada no site, continua com o mesmo erro de ssl

Viewing 15 replies - 1 through 15 (of 44 total)
  • You must be logged in to reply to this topic.