Support » Plugin: Advanced Custom Fields: Font Awesome Field » Problema ao carregar o campo com a lista de icones

  • Resolved denishollerbach

    (@denishollerbach)


    Estou com problemas, meu ACF pro esta atualizado com a ultima versão e além disso, uso o Poly lang + loco translate para fazer a tradução do meu site, tudo esta funcionando normal ja dessa forma. Talvez depois de alguma atualização do ACF ou com a ultima versão mesmo do plugin 4.0.1, parou de carregar a lista de ícones para conseguir selecionar.
    Ja exclui todos que estavam dando mensagem de incompatibilidade para fazer manualmente porém não esta funcionando do mesmo jeito.

    Já coloquei minha API token, e selecionei meu kit cadastrado com a V6 no site, e tbm selecionado no plugin… porém não consegui achar nenhum script de carregamento pelo inspecionar também e continua sem chamar meus ícones salvos no banco, só mostra se eu colocar via código mesmo a cdn etc… Pela opção do ACF não consegui deixar para carregar o script no footer nas paginas que aparecerem os ícones para testarem , devido a essa problema de não carregar a listagem

    Em meu console esta carregando todos os arquivos do plugin normalmente, então acredito que não seja problema com a tradução.

    E esta aparecendo o seguinte erro: Uncaught Error: No select2/compat/dropdownCss

    Não tenho como mandar link, por que o problema é na pagina de ACF options, criada para definir algumas coisas do tema, como as redes sociais que não aparecem os ícones.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thread Starter denishollerbach

    (@denishollerbach)

    Plugin Author Matt Keys

    (@mattkeys)

    The error you are seeing: “No select2/compat/dropdownCss” is the likely cause of these problems.

    Do you have other plugins installed that also use the Select2 library? My guess is that there is a conflict with another plugin using this same library. The “dropdownCss” feature does not exist in older versions of Select2 so that would explain the error.

    Using your browsers inspector can you look and see which version or versions or Select2 are being loaded on the page you are seeing this error on?

    Thread Starter denishollerbach

    (@denishollerbach)

    @mattkeys

    /*! Select2 4.0.3 | https://github.com/select2/select2/blob/master/LICENSE.md */

    Irei procurar fazer o teste de desativas alguns plugins para ver, porém o menos possível, sendo a maioria Campo personalizados, contato, paginação e tradução/BOT atendimento

    Plugins ativos:
    -ACF Options for Polylang
    -Advanced Custom Fields PRO
    -Advanced Custom Fields: Font Awesome
    -Contact Form 7
    -Duplicate Page
    -Loco Translate
    -Polylang
    -What The File
    -WP-PageNavi
    -WPBot Multi-Language Addon
    -WPBot Pro WordPress Chatbot

    Thread Starter denishollerbach

    (@denishollerbach)

    Ao desativar os dois plugins referente ao BOT, voltou a funcionar a listagem dos ícones.

    -WPBot Multi-Language Addon
    -WPBot Pro WordPress Chatbot

    Alguma sugestão de como resolver esse conflito? Pois é necessário o uso de ambos os plugins no meu projeto

    Plugin Author Matt Keys

    (@mattkeys)

    Is there any reason that WPBot Pro should be using Select2 in the admin area? I would think that the plugin is only needed on the frontend of the website? Do you interact with that WPBot Pro plugin in some way in the backend area?

    Looking at the source code for the free version of that plugin I do not see any mention of Select2. So I am guessing it is either only in the Pro version, or in the Multi-Language Addon.

    If you search those plugins for the text ‘Select2’ do you get any results?

    It might be possible to dequeue the Select2 script from those plugins only on the admin-side using this function: https://developer.wordpress.org/reference/functions/wp_dequeue_script/ And checking for is_admin()

    However I am not familiar enough with that plugin to know if that will have unintended side effects.

    Thread Starter denishollerbach

    (@denishollerbach)

    @mattkeys

    Agradeço pela atenção até o momento, irei procurar aqui para ver se encontro alguma menção referente ao script Select2..

    Ja entrei em contato com suporte do plugin também para ver se conseguem me auxiliar em alguma solução. Aguardando retorno, assim que tiver alguma novidade no processo mando aqui também, as vezes pode ajudar outros usuários

    Thread Starter denishollerbach

    (@denishollerbach)

    @mattkeys
    Fiz conforme me indicou, perguntei se teria algum tipo de interferência no uso do plugin para o suporte e me confirmaram que tudo bem, que não teria problema nenhum remover o script.

    function hbach_selectively_enqueue_admin_script( $hook ) {
    wp_dequeue_script( ‘select2’);
    wp_deregister_script(‘select2’);
    }
    add_action( ‘admin_enqueue_scripts’, ‘hbach_selectively_enqueue_admin_script’ );`

    Plugin Author Matt Keys

    (@mattkeys)

    Did the above code resolve the issue?

    Thread Starter denishollerbach

    (@denishollerbach)

    Sim, removi os scripts do admin, e conferi se não iria causar mau funcionamento no plugin com o suporte, os mesmos disseram que estava tudo bem que não teria problema a remoção. Voltou a funcionar normalmente o Advanced Custom Fields: Font Awesome Field

    Plugin Author Matt Keys

    (@mattkeys)

    Good to hear it!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.