[problem] WordPress MS + plesk (8 posts)

  1. beuzathor
    Posted 5 years ago #

    Hello all,
    In first, im' french so escuse if my english is not perfect.

    Last day i changed my server and now i'm with plesk 9.

    I try to transfert a first wordpress MS but i have probleme (i'm with subdomain).
    I configured wilcard with this insctructions :

    So i have this in my dns record :
    *.cash-structured-settlements.info. CNAME cash-structured-settlements.info.

    And i added the vhosts.conf files in :

    I tried to transfert my site, all is fine but all subdomain go on my plesk home page.

    So i tried a fresh install but same probleme.

    I think i must have a problem with htaccess but i'm not sure.
    For info, see my htaccess :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]

    Do someone have an solution for that ?

  2. I think i must have a problem with htaccess but i'm not sure.

    You may have a problem with your .htaccess but I think it may instead be with your VHOST setup.

    If your DNS is sending your *.your-domain.com to your server, then this should work


    When I try that on my MS installation, no matter which made up name I put into the wildcard, I get the WordPress readme.html file.

    For your domain, I get a 404 file not found. Of course, you may have deleted the readme.html file but I think Apache2 is not sending the request to the correct DocumentRoot since doing so with index.php does not work either.

  3. beuzathor
    Posted 5 years ago #

    I try to reinstall everything and do again the config because i don't understand.
    Thanks for your reply.
    I will go back if it's not ok

  4. pick your wordpress install as the primary domain on that web account.

  5. beuzathor
    Posted 5 years ago #

    I tried reinstall but same problem.

    What do you want to say by "pick your wordpress install as the primary domain on that web account. " ?

  6. beuzathor
    Posted 5 years ago #

    Arf, very hard question.
    There is some post and i think i have added all necessary option for do it :
    - added vhosts.conf file
    - added cname with *mydomain.com CNAME mydomain.com

    Maybe an order for do it is necessary ?
    Do someone have a screen for his DNS zone in plesk 9 with wordpress MS online ?

  7. The order is very important. I tagged this post as a plesk issue, and you may want to review the myriad posts about the woes of Plesk. There's a known bug among other issues

    Check the posts in http://wordpress.org/tags/plesk and this one in particular:

  8. beuzathor
    Posted 5 years ago #

    Thanks for this post. But i tried everything in it.

    - I have found other solution with unchecked the www check box in the domain management.
    - I tried to delete the domain on plex and reinstall it and doing this in differents orders
    - i tried with php in apache mode and cgi mode

    And i see there is many probleme with the email when wildcard is online but i don't want email, i want only wildcardd subdomain, that all.

    i'm confused, i try it from 24 hours now and i can't do something which must be easy. Thanks for plesk programmer (i did not take again a plesk server).

    I'm alaways ok if someone have a screen to his DNS zone ^^

Topic Closed

This topic has been closed to new replies.

About this Topic