Support » Plugin: Wordfence Security - Firewall & Malware Scan » Problem wordfence and DUO security

  • Hello,

    I run a WordPress 4.9 site and have the DUO Security 2.5.4 (2-factor authentication) plugin installed. This works without any problem.

    Recently I installed Wordfence but now the DUO plugin isn’t working anymore. After the login page I get a blank (page cannot be found) page which show http://www.mysite.com/wp-login.php in the address bar.

    Normally with the DUO plugin it shows after the login page a screen form the DUO site where you can select push/sms options. After validating on your Phone you login to the admin dashboard.

    When deactivating wordfence it immediately works again. I already received IP ranges from DUO which I placed on the whitelist.

    Any ideas which setting or exclusion I can use?

Viewing 5 replies - 1 through 5 (of 5 total)
  • WF support will no doubt chime in too, but in the meantime, IMO it’s not a good idea to run 2 different website firewalls as they could easily trip over reach other, as is happening in your case. Pick one and use that only.

    For myself, developing and managing dozens of client WordPress sites, Wordfence is an outstanding choice for site security.

    Thanks for your reply but I don’t run two firewalls, only one, Wordfence. DUO Security is only a 2 factor authentication plugin.
    See: https://wordpress.org/plugins/duo-wordpress/

    OK, but either way, clearly the two are incompatible… and WF does far more to protect your site than just a 2-factor auth mechanism will.

    From an objective outside perspective, it’s a no-brainer…. ditch the DUO and keep WF!

    Plugin Author WFSupport

    (@wfsupport)

    @bluebearmedia speaks the truth. Using two plugins that touch the same functionality is never really a good idea. Both of the plugins handle login security and using them both at the same time can cause unexpected results. To run both, you need to disable login security in wordfence by unchecking the “Enable login security” box on the options page in the Basic Options section. That should fix your issue. You could also watch live traffic in another logged in browser to see if the request is getting blocked by the firewall. You can whitelist the action from there if I am not mistaken. If these don’t work then DUO may not be compatible with Wordfence but I can’t see why it wouldn’t be.

    tim

    Thanks, but that didn’t do the trick. I disabled the login security option but it doesn’t make a difference. There’s nothing logged or blocked, only logged that I visiting the wp-login page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problem wordfence and DUO security’ is closed to new replies.