WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Problem with

[Resolved] Problem with

  • table4five
    Member

    @table4five

    I am having a problem doing the import from my WP.com blog. I created the export file, went to the WP.org Import menu, and I see this: Upload your WordPress eXtended RSS (WXR) file

    The WP.com export file is in XML. When I attempted the import, it stopped at 6.9 MB and I got this message:The uploaded file exceeds the upload_max_filesize directive in php.ini.

    I changed the file size in the php.ini to 10 MB. Does anyone have any suggestions? My blog is http://table4five.net. Thank you.

Viewing 15 replies - 1 through 15 (of 22 total)
  • table4five
    Member

    @table4five

    Oh, sorry, the import didn’t get to 6.9. I was watching it in NetPerSec and forgot to hit the reset data button. I just tried it again and it died at 1.9 MB.

    Chris_K
    Member

    @handysolo

    Are you using the WP plugin that knows about WXR files? http://www.technosailor.com/wordpress-to-wordpress-import/

    table4five
    Member

    @table4five

    Yes, I uploaded both the xmlmigrate and .php files. I went to my Plugin menu and activated WordPress XML Export.

    Chris_K
    Member

    @handysolo

    And to be clear: on your wp.org blog, under Import you see “WordPress” as an option?

    table4five
    Member

    @table4five

    Yes. I have this: Import posts from a WordPress export file

    Chris_K
    Member

    @handysolo

    Ok, thanks. Just wanted to make sure. 🙂

    So, how big is the xml file that you’re importing? Do you have access to php.ini (or your host’s support) to see what the upload_max_filesize directive is?

    This is the point where someone brighter than I usually pops in and says, “oh, you can override that with this interestingly obscure command in .htaccess…” Hopefully…

    table4five
    Member

    @table4five

    The original filesize in the php.ini was 2M. We increased it to 10M, which didn’t make any difference.

    I found another question in the forum about this, and it said to put “php_value upload_max_filesize 10M // max size in Mb” in the .htaccess file. I tried that, and it crashed the blog, and the server added a line saying that php directives go in the php.ini file. Do I need to contact BlueHost about restarting the web service?

    Chris_K
    Member

    @handysolo

    If you increased it in php.ini, I think you need to restart apache to pick that up (I think?).

    table4five
    Member

    @table4five

    All I have in my BlueHost cPanel is a link to Apache Handlers. phpAdmin had a Restart, but access was denied. So contact BlueHost then?

    Chris_K
    Member

    @handysolo

    I reckon, yeah. Not sure what else to suggest beyond that.

    table4five
    Member

    @table4five

    Thanks for your time, Handy. I’ll leave the thread open for a day or two in case anyone else picks up on it and has a suggestion. And I’ll open a support ticket with BlueHost.

    I got the impression that moving from WP.com to WP.org was going to be a few easy clicks, so it’s frustrating to find it not so easy to do.

    table4five
    Member

    @table4five

    I called BlueHost, and the problem is not with WP but with BlueHost having a limit in the phpAdmin file of 7 KB for transfers. I have to manually upload the XML file to the root directory/public html and then request that BlueHost install it.

    Hope this helps other users who are with BlueHost.

    table4five
    Member

    @table4five

    Well, I’m back, because I am impatient that way. I manually ftp’d the XML file to my host to get around the upload limit. How do I point the importer to an XML file already on the server, if that’s even possible?

    Chris_K
    Member

    @handysolo

    How do I point the importer to an XML file already on the server, if that’s even possible?

    That’s a great question. Here’s one thing to try: When you go to the WordPress importer, instead of clicking the button to browse to a file on your PC, put in the url to the file on your server (http://yourdomain.com/files/myXML.xml). Maybe that would work?

    If not I only see two options:

    1) Get BlueHost to let you upload a larger file.

    2) Hack the WP importer plugin to point to a file in the local file system.

    table4five
    Member

    @table4five

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] Problem with’ is closed to new replies.