Support » Themes and Templates » problem with wp_list_pages

Viewing 7 replies - 1 through 7 (of 7 total)
  • And what do you have in the two URI fields in Options > General?

    Do you mean URL? Both are set to http://www.21stcenturyparenting.com.

    the weird thing is, the links work on some other themes. (But I’m hooked on this theme.)

    thanks!
    renee

    OK, next troubleshooting step: you paste your header.php file to
    http://wordpress.pastebin.ca
    and post back the URL.

    Hmm.. I saw the theme is using its own function to call the Pages in the top menu. My first thought was there is something wrong with that code.
    So, I went and downloaded it, installed on a local WP – and it works correctly.

    It still might be related to the code how it calls the Pages, so I’d try to contact the theme author and describe the specifics of your server and setup.

    And I am asking once again: are you 100% sure you the “index.php” is NOT included in the two URI values in the Options? Those values can end only in directory names, never file names.

    Ok. I have been in contact with the theme author.

    But the problem was still not resolved.
    After some testing on another blog with the theme, I realized that maybe it had to do with the Permalink structure. (I had it set to “Date and name based”.) So I put it back to default, and they work fine.

    Interesting…

    Now if there’s a way to get this theme to play nicely with the pretty permalinks!

    AJKock

    (@ajkock)

    I get the same issues with this particular theme and non with any other theme. It is adding the url from the main menu’s to any sub category page’s url, when you click on that link from a sub category page.

    So if I am on hello.com/peter/ and I want to click on the about page, it changes the url to hello.com/peter/about/ instead of going to hello.com/about/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘problem with wp_list_pages’ is closed to new replies.