Support » Plugin: All In One WP Security & Firewall » problem with WordPress 5.1 RC 1

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, I just did a test using the same WordPress version in my dev site. It is working correctly correctly for me.

    This means that it is probably related to your theme. Can you test one of WordPress default themes like Twenty Seventeen? If it does not work with WordPress default themes, then it could be related to one of your plugins. In that case do a plugin test.

    Let me know how you go.

    Kind regards

    joneiseman

    (@joneiseman)

    I deleted all the other plugins and switched to the Twenty Seventeen theme and I still see the problem.

    https://drive.google.com/file/d/1awT0W1s0OprkrHoI7Jqq62yPlvPZ5rY5/view?usp=drivesdk

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, are you testing in a live server? Or are you testing in a local server like Xampp or wamp? What PHP version is running in your server?

    joneiseman

    (@joneiseman)

    I’m running a staging version of the site on the live server running php 7.2.15

    joneiseman

    (@joneiseman)

    I can reproduce the problem on a fresh install of WordPress (5.1 RC1). AIOWPS is the only plugin installed and I’m using the TwentySeventeen theme.

    https://drive.google.com/file/d/1svkZa_Y6nkAw3g7d6PwrF-YP-NFbPS0X/view?usp=sharing

    I think it’s related to the way AIOWPS is writing out the html for the paging links (with the tablenav classes).

    joneiseman

    (@joneiseman)

    I found a solution to the problem. You just need to add the “button” class to the arrows.
    Here’s the change that fixed the problem:

    adapti24@usm90 # diff ../../../../../../wp-content/plugins/all-in-one-wp-security-and-firewall/admin/general/wp-security-list-table.php .
    498c498
    <                       'first-page' . $disable_first,
    ---
    >                       'first-page button' . $disable_first,
    505c505
    <                       'prev-page' . $disable_first,
    ---
    >                       'prev-page button' . $disable_first,
    524c524
    <                       'next-page' . $disable_last,
    ---
    >                       'next-page button' . $disable_last,
    531c531
    <                       'last-page' . $disable_last,
    ---
    >                       'last-page button' . $disable_last,
    
    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, thank you for sharing your solution. The plugin developers will investigate further your solution.

    Kind regards

    joneiseman

    (@joneiseman)

    After further discussion with the WordPress team, it seems a better solution would be to add styling to the admin css. I have made a pull request on github.

    https://github.com/wp-plugins/all-in-one-wp-security-and-firewall/pull/1

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘problem with WordPress 5.1 RC 1’ is closed to new replies.