Support » Installing WordPress » Problem with WordPress 2.6

  • Resolved ysamphy

    (@ysamphy)


    I was upgrading and activating some plugins, then this message appeared:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 223115 bytes) in /home/ysamphyc/public_html/wp-admin/includes/plugin.php on line 4

    Now i cannot log in the admin panel. Please, help!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Have you tried uploading the wp-admin/includes/plugin.php again?

    You’re out of RAM. The appropriate fix is to edit php.ini and increase the memory_limit parameter (it’s probably currently at 32m; try 64m).

    More detail.

    you’d have to log out first then login again which effectively clears some wordpress cookies.

    Thanks, all, for your help. I’ve logged in and out many times but it didn’t help.

    StoneCypher, i’ve tried it too and it didn’t help either.

    What else do you think i should do?

    @ysamphy: Are you sure you logged out? Since you’re not allowed in the admin area, I mean. Did you try forcing logging out by adding /wp-login.php?action=logout to your site’s URL and hitting ENTER?

    You could also delete any WordPress cookies manually.

    @edde – I did, in fact many times already. I even tried logging in from another pc and didn’t work either.

    How can i delete wordpress cookies manually? What else could be the problem? Thanks for trying to help, edde.

    Been almost a week i cannot log in the admin panel. Help!!!

    @ysamphy: You can delete your cookies manually from within your browser.
    In Firefox, you select Options from the Tools menu; click the Privacy Tab. Click the Show Cookies button. Now find anything related to you domain in the list and delete the ones starting with “wordpress”.
    In IE go Tools -> Internet Options -> General -> Browsing History (Settings) -> View Files. Remove all relevant cookies.

    Alternatively, you might want to disable all you plugins as this saves memory. Since you can’t access the admin panel, removing them from the plugins directory is your only option. A quick way to do so, would be to rename your plugins/ directory to something like disable-plugins/ and create an empty plugins/ directory. This way you should be able to access the admin panel again. Depending on how well you theme was designed, your website might actually work (without the added functionality provided by the plugins). Then you could try adding plugins again (one by one) to see if any of these is causing the problem.

    You can check for known issues on http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.6
    At the moment it seems Stattraq 1.1.1 is the only plugin with (related) issues (“Has problems with the changed cookie/login system”).
    If you’re using this plugin, you might want to start with disabling this plugin by moving it out of the plugins/ directory.

    i Installed wordpress 2.6 works fine so far except a small glitch, the first admin.php file or when you click on my dashboard, it display the screen for 2 seconds and disappears and displays the following code

    http://myads.free-site-host.com/adjs.php?n=054893488&what=zone:10&withText=1&exclude=,'>http://myads.free-site-host.com/adjs.php?n=592077151&what=zone:10&withText=1&exclude=,'>http://myads.free-site-host.com/adjs.php?n=558656767&what=zone:10&withText=1&exclude=,'>

    If i click on the url, and move my mouse over the stop button and push enter then click stop real quick i can see it, but any longer i
    can’t…. ALL other pages work fine, cept this one small glitch
    any ideas to a fix

    *Yes i have already cleared cache…
    I’m Using
    Browser: Firefox 3.0
    OS: Vista(I Hate By The way… Xp/linux won’t run on this system either {Drivers} Grrr)
    Host: Free-web-host

    Anything to fix this would be great.

    ~jdnforjc~

    ~Myspace.com/jdnforjc~

    @edde – It helped! Maybe your alternative suggestion. Thanks a lot. I believe there are more than one plugin that are incompatible, mostly those not very important. After enough headache i decided to delete all of those.

    Thank you for helping me out, edde. My thumps up for you!

    @ysamphy
    i knew that edde’s suggestion would work… just i don’t know about mine LOL
    Glad you got your issue fixed

    @ysamphy: No problem! Others helped me too…

    edde: the both way you suggested did not work for me. Clear cookies and disable all the plugins. Any other solutions.
    My problem is the admin cannot show up.

    assuming you’re tried logging in the usual way and still get that, by now, pesky “please log in again.” notice,

    1. go to your home page.
    2. in the admin section of the sidebar you should see a “log out” link. click on that.
    3. then the screen will/should refresh. log in by clicking on the “log in” link under admin.
    4. suppy your username/password
    5. and you should be able to access your dashboard

    hello

    little same problem for me, but my file with problem is template.php

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 4864 bytes) in /home/erhangaz/public_html/wp/wp-admin/includes/template.php on line 341

    on line 341 sometimes changes to different lines. i tried whatever you said under this topic. but any of them didn’t help me…

    what should I do?

    erhangazi.com

    thanks

    I tried everything listed here but can’t get past the admin login. Using Safari, Camino, and FF on a Mac.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Problem with WordPress 2.6’ is closed to new replies.