WordPress.org

Forums

Problem with WooThemes Original Premium News Images (28 posts)

  1. mister reece
    Member
    Posted 5 years ago #

    Hi everybody,
    I have a blog that I'm helping a friend out with. I searched every site I could that had a lay out like what he wanted and what I thought would work best for him. We eventually stumbled across WooThemes and were going to buy the News Press theme until we saw the Original Premium News.

    For some reason, we he tries to upload photos for the custom field thumbnails, he gets a "woo themes upload error- image failed test" error (or something close to that*). I can't figure out why, either? Has anyone seen this and know how to solve it?

    I know someone will probably tell me to go to the WooThemes forum for support and help, but they don't give you access to the forum if you use a free theme. And in my case, I would have gladly paid for this theme because it is almost exactly a lay out that would really serve us well on his site. Can anyone lend me a login and password to the WooThemes forum via DM? I just need to see if anyone has a solution and i think it's kinda sh*tty that they don't support the one free theme they have up there. I have tried emailing them and have gotten some really useless responses.

    Or does anyone know any themes that are like the Original Premium News theme that isn't as buggy? I'm looking for something that has the "featured posts" AND "featured videos."

    Thanks!

  2. mister reece
    Member
    Posted 5 years ago #

    Oh, and I've gone through almost every search result on this forum about WooThemes and the Original Premium News theme, and haven't seen anyone with a similar problem or solution. If anyone knows anything, I would really appreciate it.

  3. Mark / t31os
    Moderator
    Posted 5 years ago #

    If it's an error related to the woo uploader that's included with their theme's, it's not something someone who is unfamiliar with the code will really be able to help you with, this is specific to the woo code.. so i can only give you my best guess..

    It could possibly be that it's having a problem creating the upload's directory for the theme, which i believe (i could be wrong) resides in the uploads folder as a seperate directory.. something like "woo_uploads" or something to that degree... if i remember correctly..

    I'll take a look at the theme and see what generates that error, it should help narrow down what the issue is.. will reply again shortly..

  4. Mark / t31os
    Moderator
    Posted 5 years ago #

    Well i checked the files and i cannot find the text to you posted.. (the word failed for example exists only in one place, and thats inside a code comment)..

    Can you provide the error message in it's entirety.. and i'll track down what produces that message..

  5. mister reece
    Member
    Posted 5 years ago #

    "WooThemes Upload Error: Image - Specified file failed upload test."

    I'm barely learning about coding and all of this myself on my own. And it seems like I have an incredibly long way to go, so I apologize for not being able to do it myself.

  6. Mark / t31os
    Moderator
    Posted 5 years ago #

    Ok found it, it's part of an ajax response to image uploads..
    This is the line that triggers that error i believe.

    if(!empty($uploaded_file['error'])) {echo 'Upload Error: ' . $uploaded_file['error']; }

    /functions/admin-iterface.php - Line 658
    Which is in turn triggered by this line.

    $uploaded_file = wp_handle_upload($filename,$override);

    As far as i can tell(at a guess), it's a problem with permissions, like i said initially i think the problem is related to the creation or non-existence of the woo upload directory... let me install the theme and i'll see what happens for me, one min...

  7. mister reece
    Member
    Posted 5 years ago #

    t31os_, dude, you don't have to go through all the trouble, but I seriously thank you for trying to help...! I'm at my wit's end. Just don't know what to do anymore!

  8. Mark / t31os
    Moderator
    Posted 5 years ago #

    Ok looks like it's changed since i last saw a woo theme's code, this new framework just uses your WordPress uploads directory.

    In my case, uploading an image placed them into..
    127.0.0.1/wp-content/uploads/2010/02/testimagefild.png

    I can only guess, but i'd say the problem is with your uploads directory permissions, if one currently exists... or it could be a problem with where the upload path points to (Admin > Settings > Misc) ..
    http://codex.wordpress.org/Settings_Miscellaneous_SubPanel#Miscellaneous_Settings

    I'd guess that getting the uploads directory working (woo theme aside) would resolve the problem, since the theme framework (as far as i can tell) utilises whatever upload location you've already setup for WordPress (it doesn't create it's own, like i'd seen in their previous code).

    P.S. It's no trouble, takes me a few seconds to check..

  9. mister reece
    Member
    Posted 5 years ago #

    But would the uploads directory cause it to work sometimes and then not work sometimes? Would the settings be changed when upgrading to a newer version of WordPress?

    I'm going to give this settings suggestion a shot and let you know what happens. Hopefully I can get it resolved in case anyone else has similar issues.

  10. Mark / t31os
    Moderator
    Posted 5 years ago #

    Well i'm only making a best guess here, i can't really say for sure, it's one possible cause i suppose.

    I've not used Woo Theme's extensively myself so i can't say i know a great deal of how the framework operates, i've simply given you my observations following the installation earlier, that's a question best answered by the Woo peoples... :)

    Test some images using the media library, or using the insert media button in a post, and see how that works out, you'll at least know more specifically where the problem lies once you've done that .. (with uploads in general or just in the woo interface)..

  11. mister reece
    Member
    Posted 5 years ago #

    Well, I tried changing the settings, as you suggested for the uploads folder. Every photo is STILL failing the upload test.

    Even if I upload the photo to my media folder and use the custom setting to insert the url, hoping that it would still autoresize the thumbnail, nothing.

    This seriously makes me think very low of WooThemes because they seem to not be able to support a theme they made. I would have gladly bought this theme were it for sale. This is ridiculous.

  12. Mark / t31os
    Moderator
    Posted 5 years ago #

    It's important uploads are working in WP, as functionality in the theme is dependant on that working.

    It works here beautifully, so i can't fault the theme myself, it works just as well as the standard media uploader, perhaps better.

    What is your upload path set to, and do you have an uploads folder present? ..if so, what permissions are set on that directory?

  13. mister reece
    Member
    Posted 5 years ago #

    I STILL can't get this theme to work right. I have tried a lot of suggestions I have seen all over the web, and nothing.

    Uploads are working just fine (I guess?) and I have them under "/wp-content/images." I had them under "/wp-content/uploads," but I'm going to try this now and see what happens.

    I don't know how to set the permissions for any of these folders? Can you explain please?

    Thanks

  14. mister reece
    Member
    Posted 5 years ago #

    Any chance anyone can help? Please? 11teen thousand cool points for whoever can help, payable by monopoly money.

  15. tscross
    Member
    Posted 5 years ago #

    ya i also have this problem! can anyone help?

  16. gilig
    Member
    Posted 5 years ago #

    Setting permissions:

    If you are uploading through an FTP (for instance, I am using FileZilla), once you login you can see the directory for your website and there will be showing some columns which are:

    - file/folder name
    - size
    - type
    - last modified
    - PERMISSIONS / ACCESS RIGHT

    Right click on the last column, and you will be able to change the permissions. If the setting shows 755 it means something (which I forgot whether it is allowing access to write or the other way). As my best guess, you might have 777 which you have to change it into 755.

    - I could be wrong, though, sorry -

  17. gilig
    Member
    Posted 5 years ago #

    By the way, thanks to t31os_ for your explanation. It also works beautifully in my website http://www.sekolahku.info

    Thank you!

  18. foxinni
    Member
    Posted 5 years ago #

    Hey all,

    Our forums also seems to be buzzing with this issue.

    The "Specified file failed upload test" comes directly from the /wp-admin/includes/file.php more specifically the wp_handle_upload function. I know this because I wrote it all myself fro the WooFramework. :P

    Many times the users who have issues with the "Custom Field" uploader also have issues with their normal WP Uploader; sometimes not.

    For more detail:

    // A properly uploaded file will pass this test. There should be no reason to override this one.
    	if (! @ is_uploaded_file( $file['tmp_name'] ) )
    		return $upload_error_handler( $file, __( 'Specified file failed upload test.' ));

    As you can see, the explanation says that a properly uploaded file will pass the test. So the error must be due to the file being "Put" some where after the upload... only not to be put there at all. Hence a permissions error.

    MANY people have no problem at all, where some claims it happened "all of a sudden/overnight".

    I'm personally stumped as I've not worked on the uploader to quite a while seeing that it's working really well.

    I'm still open to suggestions. As I'm trying to keep free and paying customers happy. :)

    Cheers,
    Fox
    WooThemes Developer

  19. kilpatrick
    Member
    Posted 5 years ago #

    Yes I have this problem too. Must admit its doing my head in. Its a big shame as its a lovely theme and Im surprised it was free. I also bought productum earlier in the week which appears to work fine on the same server with the same permissions.

    Ill book mark this and hopefully an answer will be forthcoming.

  20. kilpatrick
    Member
    Posted 5 years ago #

    Hi Foxini,

    If it is of any help, the error message is at the top of the new posts page even before you try to upload an image. Infact the error is on the new post page even before you put a title in and start to type the post out. It appears the error is there prior to uploading.

  21. kilpatrick
    Member
    Posted 5 years ago #

  22. HellKatzX
    Member
    Posted 5 years ago #

    Using the full image url in the "Image" field works for me

  23. jordanwinston1
    Member
    Posted 5 years ago #

    hey everyone - i found out how to make it work.

    You're going to have to manually upload the file to your FTP or any server, whether it be an image hosting service if you dont have your own webhost, etc. Once you do that, go into add a new post or edit your existing post.

    at the bottom of the post (under typebased custom settings), in the field above where it asks you to choose file, etc., you're going to put the address of your image and then click SAVE and it works perfectly.

    So, basically, you put your full address: http://www.yourdomain.com/images/imagename.jpg or whatever your path is.

  24. betzy
    Member
    Posted 5 years ago #

    i dont think the problem is with the uploader, ive tried to put manualy the custom fields image, ive put "image" at the name and the full path to the "value" and guess what ... it doesnt display the custom image.

    I`ve tried the theme on two diferent hosts and on one of them is working like a charm but on the other one is not working .... so ...

  25. foxinni
    Member
    Posted 5 years ago #

    Hi All (again)

    @betzy: You're doing it wrong. :P You don't need to add the custom field manually. It's already been created at the as a Custom Setting, perhaps just lower down the page... http://foxinni.com/screens/cf-20100719-123944.png

    Further more I think I've found a possible fix. One has to add a override into the framework admin-interface.php file. I'm not sure if it works.. but it should bypass the error message, causing the WP file upload function to return to soon because of the error check.

    Here is the possible fix: http://foxinni.com/screens/upload_fix-20100719-123127.png

    Good Luck.
    Fox

  26. lai24luv
    Member
    Posted 5 years ago #

    Has anyone found a solution that works? I've tried ALL of the suggestions posted here, and I still can't get the image in the Featured section to work.

    Thanks,
    Lani

  27. MrSlash
    Member
    Posted 4 years ago #

    I have the same problem. I'm using wordpress 3.
    The permission are OK cause I'm using localhost and not FTP.

    But i noticed If i try to delete the code

    // A properly uploaded file will pass this test. There should be no reason to override this one.
    	if (! @ is_uploaded_file( $file['tmp_name'] ) )
    		return $upload_error_handler( $file, __( 'Specified file failed upload test.' ));

    the problem still exists. I don't know why. Even if there's no sting like "Specified file failed upload test." in the entire site.
    I've found on this forum some files that could work, but they're for wordpress 2.5.
    Anyone found a fix for this issue?

  28. valaryu
    Member
    Posted 4 years ago #

    i think i've found a not-so-cool solution but it works for me..
    you just have to go to feature.php, when you open it scroll down to the
    bottom where you'll see the 'if' condition to display the image specified in the custom field..

    you just have to comment the li code where the custom field has not been completed .. and copy and paste the li code where the if condition is evaluated to true

    <?php if ( get_post_meta($post->ID, 'image', true) ) { ?> <!-- DISPLAYS THE IMAGE URL SPECIFIED IN THE CUSTOM FIELD -->
    
    <!-- copy this line  --> 	<li <?php if ($counter == 5) { ?>class="last"<?php } ?>><a href="#post-<?php the_ID(); ?>">
    <!-- copy this line  -->        <?php woo_image('height=57&width=100&link=img'); ?>
    
                </a></li>			
    
    		<?php } else { ?> <!-- DISPLAY THE DEFAULT IMAGE, IF CUSTOM FIELD HAS NOT BEEN COMPLETED -->
    
    <!-- comment this line -->            <!--<li <?php if ($counter == 5) { ?>class="last"<?php } ?>><a href="#post-<?php the_ID(); ?>"><img src="<?php bloginfo('template_directory'); ?>/images/no-img-thumb.jpg" alt=""/></a></li>   -->
    
    <!-- paste it here  --> 	      <li <?php if ($counter == 5) { ?>class="last"<?php } ?>><a href="#post-<?php the_ID(); ?>">
    <!-- paste it here  --> 	      <?php woo_image('height=57&width=100&link=img'); ?>

    the only drawback is that it uses the first image inserted in the post [0]

Topic Closed

This topic has been closed to new replies.

About this Topic