Support » Plugin: Freesoul Deactivate Plugins » Problem with WMPML

  • In this page the plugin to deactivate another plugin (woocommerce product filter) do not function.

    In the italian version it’s ok.
    I installed this plugin to fix a jquery error that gives the woocommerce product filter plugin on this page, where there is a script that opens an iframe on another site.
    I Deactivating it everything works correctly, unfortunately I cannot remove the plugin that I need in other pages.

    It doesn’t only work in english, i currently use wpml, can you help me?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jose

    (@giuse)

    HI @musicasara

    I’ve tested WPML in the past and had no problem.

    Be sure:
    – you set the unwanted plugins on all language versions. It’s not enough to set them only for the main language
    – you don’t have problems with the cache of Autoptimize

    Inspecting elements on the page where you need help I’ve seen the jQuery error is originated by this file: https://www.gioielleriaguidetti.it/wp-content/cache/autoptimize/js/autoptimize_single_9dc1a505b7d4b513560233f41fb25a99.js?ver=5.5.1

    This means that even if you disable the plugin that is giving a problem, the script of that plugin is included in the cache of Autoptimize.

    So, delete all the cache of Autoptimize, and be sure you don’t concatenate the scripts, in another case disabling plugins will not help you, cause their scripts will be served by the concatenated files.

    Let me know if it helps.

    Re. the JS error; maybe try adding wp-content/plugins/woocommerce-products-filter/ to the comma-separated JS optimization exclusion list?

    be sure you don’t concatenate the scripts, in another case disabling plugins will not help you, cause their scripts will be served by the concatenated files

    Autoptimize actually checks for JS/ CSS on every page request and only puts JS/ CSS in the concatenated that is found in the page requested. As such you should be able to deactivate plugins and not seeing their JS in the optimized code.

    hope this helps,
    frank (ao dev)

    Plugin Author Jose

    (@giuse)

    @optimizingmatters thank you very much for your intervention. This information is really important.

    So, I suppose the concatenated file is created when the page is visited for the first time if the concatenated file for that page still doesn’t exist, right?
    And every page has its own concatenated file, hasn’t it?

    If so, probably the cached file of Autoptimize was created before disabling the unwanted plugin. If this supposition is right, after clearing the cache of Autoptimize, it should work.

    @musicasara Have you tried clearing the cache of Autoptimize?

    And every page has its own concatenated file, hasn’t it?

    only if the aggregated CSS/ JS is different from other pages, if it is the same it is reused from cache

    So, I suppose the concatenated file is created when the page is visited for the first time if the concatenated file for that page still doesn’t exist, right?

    almost; if the concatenated file for that exact combination of aggregated CSS/ JS still doesn’t exist 🙂

    If so, probably the cached file of Autoptimize was created before disabling the unwanted plugin.

    unlikely, as in that case AO would “see” that the aggregated CSS/ JS is different and create a new version in cache.

    page caching (which AO does not do) can obviously create yet another layer of complexity 😉

    Plugin Author Jose

    (@giuse)

    @optimizingmatters Honestly, I didn’t know the concatenated files were managed in a so efficient way. Amazing! So, Autoptimize and Freesoul Deactivate Plugins can work together even if you concatenate the scripts/stylesheets.

    @musicasara I see the page where you have problems is probably a grandchild page, isn’t it?
    I tested Freesoul Deactivate Plugins with translated child pages, but not with grandchildren translated pages. I will test it and let you know if I can reproduce the same problem.

    Until then, if you want a quick and dirty solution, if it’s only on one page, you can use the settings CUSTOM URLS => FRONTEND URLs
    Set there the URL where you have problems, those options will have the priority on all other options, and let me know if it works.

    It’s a dirty solution because the deactivation of the plugins should work also on translated grandchild pages. If after my tests I see this is really an issue, the next version of the plugin will have this bug fixed.

    Plugin Author Jose

    (@giuse)

    Hi @musicasara

    the translated versions of grandchildren pages are a problem for FDP.

    The only way to set the unused plugins for this kind of page is by using the Custom URLs settings as written in my previous comment.

    In the next version, when in the Singles settings FDP detects this kind of page, it will add a custom URL without you need to manually do it. It will be a workaround but the user will not need to do anything, and it will work.

    Until the new version is not available, I suggest you use CUSTOM URLS => FRONTEND URLs.

    Have you already tried with Custom URLs?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.